Page MenuHomePhabricator

Associate red links on Wikibase client wikis with items in the Wikibase repo
Open, Needs TriagePublic

Tokens
"Like" token, awarded by Mvolz."Love" token, awarded by Sannita."Love" token, awarded by Daniel_Mietchen."Love" token, awarded by Salgo60."Love" token, awarded by Jane023.
Assigned To
None
Authored By
Amire80, Dec 18 2018

Description

This is a feature request.

Wiki links to non-existent pages, best known as "red links", are A Good Thing. They encourage the creation of new pages, and they automatically spring to life on many pages when the relevant article is created.

Wikidata has many items about which there could be an article in Wikipedia, Wikivoyage, or another wiki, but which doesn't exist yet. Sometimes it exists in other languages and sometimes it doesn't exist in any language. It would be great to have a robust way to associate red links in Wikibase client wikis with items on the Wikibase repo. Such a thing has been discussed informally in meetings and mailing lists for a few years, but I'm not aware of a task that documents this wish, so I'm creating it. If there is another one, please merge it.

Currently red links just point to creating a page. This is generally useful, but associating a red link with a Wikibase item can provide several advantages:

  • Disambiguation. Different people and things may have the same name. When this happens, creating an article with this name will create unwanted blue links.
  • The title of the article is not necessarily known before it's created. Different editors may create different red links to what is supposed to be the same article. While it does happen that several Q items exist about the same thing, their uniqueness is usually managed better.
  • The possibility of knowing that a corresponding article exists in another language. This allows several things, most notably suggesting to translate it and pre-filling its title in Content Translation.
  • The possibility of showing some useful information from Wikidata property values using a tool such as ArticlePlaceholder.
  • The possibility of pre-filling some information from Wikidata when creating a new article. This could be done by integrating additional tools such as Reasonator or Content Translation, but the association suggested here is a necessary step on the way to having this.

Some Wikipedias handle this using a template, for example {{Interlanguage link}} in the English Wikipedia or {{Lien Wikidata}} in French. However, because of the nature of how templates work, such a solution is not robust enough:

  • This is not integrated with Wikidata at all. Wikidata doesn't know that the red link or the empty page to which it leads are associated with the Q item.
  • It is not properly integrated with Visual Editor. For VE it's just a generic template like any other and not a first-class link object.
  • The implementation and the parameters are different in different wikis, and the whole point of such a feature is supposed to be uniformity across wikis.

So such a feature either requires new wiki syntax (just a crazy idea: [[[Q42|Douglas Adams]]] or maybe [[item:Q42|Douglas Adams]]; but it can be anything else), a magic word, or special treatment of templates like {{Interlanguage link}} in Visual Editor.

When this is implemented, the whole nature and design of links in general and red links in particular may change, so it's a big request, but it has to start somewhere :)

Event Timeline

Amire80 created this task.Dec 18 2018, 2:30 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 18 2018, 2:30 PM
Amire80 updated the task description. (Show Details)Dec 18 2018, 2:52 PM
Amire80 updated the task description. (Show Details)Dec 18 2018, 3:11 PM
cmadeo added a subscriber: cmadeo.Dec 18 2018, 3:12 PM
Jane023 added a subscriber: Jane023.
Amire80 updated the task description. (Show Details)Dec 18 2018, 7:44 PM
Salgo60 added a subscriber: Salgo60.
Salgo60 added a subscriber: Lucie.EditedDec 18 2018, 8:40 PM

I 100% support this feature that Wikipedia starts move away from linking strings to link THINGS I can see many more possibilities by linking Things not strings

  • when the new article should be written we can
    • use Scholia per subject or author e.g. Mason Ellsworth Hale ==> Scholia Q18633472 to present what is in Wikidata
    • suggest sources: finding other Wikipedia articles with the same subject/type of persons and based on those articles suggest sources
    • book recommendations to use as sources when writing the article: Finnish National Library presented last week on SWIB18 a tool Annif were you use machine learning for extracting subjects from a text and then could send this to the Finnish National Library to get suggestion on books see tweet I guess this could be applicable if we link things
    • picture recommendations: in Sweden we have a community that have scanned 600 000 old pictures and used machine learning and face recognition to group pictures and add metadata. We have in Wikidata same as using Property:P4819 ==> we could easy suggest images to use if we link to Things in Wikidata
    • easier create an article stub: Earlier this year I was interviewed by @Lucie who is researching how to use Wikidata information in a better way and how to create a stub as a start for writing your own article easier see her at researchgate or on Scholia I guess she also would like to see this feature....
Amire80 updated the task description. (Show Details)Dec 18 2018, 8:51 PM
Sannita added a subscriber: Sannita.
leila added a subscriber: leila.Dec 19 2018, 8:55 PM
Mvolz awarded a token.Dec 21 2018, 8:49 AM
Amire80 updated the task description. (Show Details)Dec 29 2018, 12:50 PM

Bugreporter closed this task as a duplicate of T123021: Implement connection between nonexistent pages (red links) and Wikidata items.

It's quite amusing that the dupe is my own :)

Amire80 reopened this task as Open.Jan 19 2019, 9:03 PM

Actually no, sorry, it's not a dupe, even though it's related. T123021 is about ContentTranslation, and this one is about Wikidata itself.

Amire80 updated the task description. (Show Details)Mon, Jul 15, 7:12 AM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMon, Jul 15, 7:12 AM