Page MenuHomePhabricator

Homepage: "Your Recent Questions"
Closed, ResolvedPublic

Description

Both the mentorship module and the help module contain ways to post questions on other pages. Some newcomers may look for answers by returning to their homepage to try to get over to the place where their question has been posted. This feature may help them find and read their answers more easily.

Specifications

  • Mockups for this capability are visible here, shown with the mentorship module.
  • When the newcomer has asked a question, a new header should appear under the "Ask the help desk"/"Ask your mentor a question" button that reads, "Your recent questions".
  • Listed under that header should be the most recent three questions that the user has asked via that module.
  • They should be listed with a snippet from the beginning of the text with an ellipses. So if the user's question was, "hello Cloud atlas, how do i add a photo to an article?", the snippet might read, "hello Cloud atlas, how do i a..."
  • Underneath the snippet, we should list how long ago the question was posted.
    • Today: "Posted today"
    • Yesterday: "Posted yesterday"
    • 2 days ago or more: "Posted 65 days ago". That said, it would be ideal to use the same logic here that we used in T217105 to break this timeline into weeks, months, and years.
  • If a link to a question no longer works, because the page has been archived or the question has been deleted/reverted:
    • The snippet of the question should be greyed out and italicized.
    • The line underneath should read like "Posted 65 days ago (archived)". If the revision is available (hasn't been deleted) then "archived" should be a link to go to the revision where the question was originally posted.
    • This should all have a tooltip that reads, "This question has been archived likely because it was asked a long time ago."
    • After posting a question via mentorship or help, the module display should be updated without requiring a page reload.

The biggest open concern is how to handle the cases when questions are no longer present at their original links because they have been archived, deleted, or reverted. We don't want to silently take something away from the user. See T215986 for a discussion of these situations and ideas for how to deal with them.

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : masterShow recent questions for mentorship and help modules

Related Objects

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

Will the snippet contain the title of the question? It would be great, so that newcomers will try to improve their titles to avoid the endless and boring titles like "question", "hello"...

@kostajh has provided some solutions about links to questions on T215986#5036266. However, he says that the links can be stale, which is a concern to me. Especially for users who will return to the wiki after an long offline period. They expect a reply they will never find.

Tagging @Urbanecm for ideas on how to do this -- he had some thoughts during our meeting today.

FYI @Trizek-WMF.

I have several ideas how to fight with the constantly changing links because of archivation. The solution that came to my mind is the following:

I think we're able to determine if a question is in the current version of the Helpdesk. I'm also sure we can determine when the question was asked. We also should be determine the archive it should be in (not now, since the archive pages names are created sequentially, but that can be easily changed to WP:Potřebuji pomoc/Archiv YYYY-MM). If the archive was called Archiv YYYY-MM, we can essentially say "If the question isn't at the current Helpdesk, it must be in this archive".

We can probably change how archiving works to Archiv YYYY-MM system and then check if the question is visible now, and if it isn't, link to the archive (presumably check before if it is in the archive, because questions can be reverted theoretically).

If we don't want to change the system, or we want to deal with questions before the change, we can do something else. We can check which is the last existing archive when a question was posted, and record this information. Then, the question must be at the helpdesk, in the recorded archive, or in the recorded archive plus one.

I hope this is understandable. if not, ask!

Korean Wikipedia has a monthly help desk, like Wikipedia:Help desk/April 2019. Formatting the help desk like this directly would ease our work: it does not need to move things to archive, because the message you post is placed where it will be archived. The link remains valable without any archiving system needed.

@MMiller_WMF is going to put a solution on this task

The Growth team is considering this task for the hackathon. We're happy to collaborate with other participants on this.

MMiller_WMF updated the task description. (Show Details)Apr 11 2019, 6:32 PM

I re-specified specifications in the task description in how to deal with broken links, and this is now ready for development. We still believe that our way of handling the broken links is not ideal, but we can revisit it.

MMiller_WMF updated the task description. (Show Details)Apr 13 2019, 1:11 AM

I just updated the link in the description to more modern mockups showing the feature.

kostajh updated the task description. (Show Details)Apr 24 2019, 3:03 PM

Change 506339 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] (wip) Show recent questions for mentorship and help modules

https://gerrit.wikimedia.org/r/506339

kostajh updated the task description. (Show Details)Apr 25 2019, 5:37 PM
kostajh updated the task description. (Show Details)Apr 26 2019, 5:56 PM

Here's what the feature looks like in my dev environment:

@MMiller_WMF @Catrope @kostajh I would propose to move the "(archived)" link right next to the greyed out title, to keep consistency with link positioning:

Change 506339 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Show recent questions for mentorship and help modules

https://gerrit.wikimedia.org/r/506339

Etonkovidova added a comment.EditedApr 30 2019, 4:23 PM

@MMiller_WMF

  • Mentors are assigned permanently - when mentors remove their names, users are still assigned to mentors that are no longer on a Mentors list.
  • Text excerpts would be saved and permanently displayed at they were at the moment of posting - subsequent modifications would not affect the text excerpt displayed. Navigation to the post that was modified is affected - a user will be redirected to the top of the page (the content table) which is ok.
  • undo and rollback actions would not change the archived status. (I hink it was mentioned by @Urbanecm in some phab task).
  • deleted posts will have archived status
  • Any markup entered in 'Ask you mentor a question' form will be displayed correctly on a mentor User talk page, but the text excerpt in Mentorship module will display markup.

FYI, filled T222208 - relevant to this feature.

Etonkovidova updated the task description. (Show Details)Apr 30 2019, 9:01 PM
Etonkovidova updated the task description. (Show Details)
Etonkovidova added a comment.EditedApr 30 2019, 9:20 PM

@MMiller_WMF - notes on items marked with .

(1) (actually for @Cntlsn)

Mockups for this capability are visible here, shown with the mentorship module.

Only two tiny observations

  • In the mockup the headers "Your mentor" and "Your recent questions" have a larger visual difference in terms of color contrast between two headers, and, maybe in a font size. Presently "Your mentor" (18px, #54595D) and "Your recent questions" (14px, #222222).
  • Mentorship 'Ask your mentor a question' has 14px and in Help module "Ask the help desk" has 12.6 - since the both labels have 'Ask' word and the modules are in proximity, probably the consistent font-size should be better?

(2)

Underneath the snippet, we should list how long ago the question was posted.
Today: "Posted today"

Presently, the time stamp shows exact time interval - e.g. "Posted 7 min ago" which is probably fine. Just marked it since it's different from the specs.

(3)

This should all have a tooltip that reads, "This question has been archived likely because it was asked a long time ago."

A question may be marked archived for different reasons, and although the tooltip uses the word "likely", the assumption may look incorrect.

@Etonkovidova -- I have some follow-up questions for you:

  • Mentors are assigned permanently - when mentors remove their names, users are still assigned to mentors that are no longer on a Mentors list.

Why did you add this on this task? Was this a mistake?

  • Text excerpts would be saved and permanently displayed at they were at the moment of posting - subsequent modifications would not affect the text excerpt displayed. Navigation to the post that was modified is affected - a user will be redirected to the top of the page (the content table) which is ok.

Are you saying that if the text of a question is modified, the link continues to remain active, and the module on the homepage shows the original text, but the link does not bring the user to the right header?

  • undo and rollback actions would not change the archived status. (I hink it was mentioned by @Urbanecm in some phab task).

I don't understand this one. When I try to use "undo" to remove a question from a talk page, this does make it archived. But the issue I filed yesterday says that when the undo is itself undone, the question does not go back to being unarchived. Is that what you're saying?

  • Any markup entered in 'Ask you mentor a question' form will be displayed correctly on a mentor User talk page, but the text excerpt in Mentorship module will display markup.

I am fine with this.

Presently, the time stamp shows exact time interval - e.g. "Posted 7 min ago" which is probably fine. Just marked it since it's different from the specs.

I am fine with this.

A question may be marked archived for different reasons, and although the tooltip uses the word "likely", the assumption may look incorrect.

I am fine with this.

@Etonkovidova -- I have some follow-up questions for you:

  • Mentors are assigned permanently - when mentors remove their names, users are still assigned to mentors that are no longer on a Mentors list.

Why did you add this on this task? Was this a mistake?

You're right - the questions was also on T216631: Homepage: mentorship module and confirmed by @SBisson that the mentor assignment is permanent. So, should there be any follow up on it or we are ok to have mentorship assignment work as it does now?

  • Text excerpts would be saved and permanently displayed at they were at the moment of posting - subsequent modifications would not affect the text excerpt displayed. Navigation to the post that was modified is affected - a user will be redirected to the top of the page (the content table) which is ok.

Are you saying that if the text of a question is modified, the link continues to remain active, and the module on the homepage shows the original text, but the link does not bring the user to the right header?

Sorry, the navigation is incorrect only when a revision cannot be displayed - all according to the specs.

  • undo and rollback actions would not change the archived status. (I hink it was mentioned by @Urbanecm in some phab task).

I don't understand this one. When I try to use "undo" to remove a question from a talk page, this does make it archived. But the issue I filed yesterday says that when the undo is itself undone, the question does not go back to being unarchived. Is that what you're saying?

Yes, that is it.

Etonkovidova updated the task description. (Show Details)May 1 2019, 7:20 PM

Resolved from QA point of view.

Thanks. This feature looks good to me, so we will keep it in my column until we are good with it in production next week.

Cntlsn added a comment.May 2 2019, 9:59 AM

(1) (actually for @Cntlsn)

Mockups for this capability are visible here, shown with the mentorship module.

Only two tiny observations

  • In the mockup the headers "Your mentor" and "Your recent questions" have a larger visual difference in terms of color contrast between two headers, and, maybe in a font size. Presently "Your mentor" (18px, #54595D) and "Your recent questions" (14px, #222222).

This is ok, and the design treatment is already present in other modules

  • Mentorship 'Ask your mentor a question' has 14px and in Help module "Ask the help desk" has 12.6 - since the both labels have 'Ask' word and the modules are in proximity, probably the consistent font-size should be better?

This was addressed in T218966#5147913

MMiller_WMF closed this task as Resolved.May 30 2019, 12:11 AM

I've tried this out in production and it works well. We also see users repeatedly clicking these links via EventLogging.