Page MenuHomePhabricator

Deploy core version of watchlist for AMC users
Closed, ResolvedPublic2 Story Points

Description

NOTE: deployment date: Monday, Oct 28, 2019

Background

In T225127: Display core version of watchlist page for AMC users we made changes to the core watchlist page on mobile so that we can display it to AMC users. Now we're ready to deploy

Acceptance criteria

  • A SWAT deploy has enabled the core version of watchlist page to all AMC users (on all projects)

QA steps

  • on mobile, with AMC turned on, go to watchlist page
  • new version of watchlist should appear

Developer notes

$wgMFUseDesktopSpecialWatchlistPage is the flag to use.

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterEnable the desktop Special:Watchlist on AMC mode

Event Timeline

Restricted Application added subscribers: Masumrezarock100, Aklapper. · View Herald TranscriptOct 14 2019, 9:44 AM
nray added a subscriber: nray.

looks like the config needed here is $wgMFUseDesktopSpecialWatchlistPage. I think this is ready to be estimated?

Restricted Application added a subscriber: Dereckson. · View Herald TranscriptOct 15 2019, 4:04 PM
Jdlrobson updated the task description. (Show Details)Oct 15 2019, 4:05 PM
ovasileva set the point value for this task to 2.Oct 15 2019, 4:06 PM

Looks all good! @Johan Should we add this announcement to the next Tech news?

Johan removed a project: User-notice.

Change 546656 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Enable the desktop Special:Watchlist on AMC mode

https://gerrit.wikimedia.org/r/546656

Change 546656 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Enable the desktop Special:Watchlist on AMC mode

https://gerrit.wikimedia.org/r/546656

Jdlrobson reassigned this task from Jdrewniak to ovasileva.Mon, Oct 28, 7:43 PM
Jdlrobson added subscribers: Jdrewniak, Jdlrobson.

@ovasileva this will ride the train. Available in AMC on Wednesday to mediawiki.org and all wikipedias Thursday (provided all goes to plan). Not sure how you want to deal with QA.

Deployment date is Monday. But I am still seeing the MobileFrontend version of Watchlist.

Deployment date is Monday. But I am still seeing the MobileFrontend version of Watchlist.

@Masumrezarock100 - see T235414#5613072 - we've decided to let it ride the train, meaning it will be available everywhere by Thursday this week.

@ovasileva this will ride the train. Available in AMC on Wednesday to mediawiki.org and all wikipedias Thursday (provided all goes to plan). Not sure how you want to deal with QA.

Let's QA on Thursday

Looks good to me. But the trailing semicolon after an username is kinda annoying.

Looks good to me. But the trailing semicolon after an username is kinda annoying.

Patches welcomed :) https://phabricator.wikimedia.org/T233649

After this change, my watchlist is more than double the width of my screen! Apparently neither the size of the buttons nor the length of edit summaries can fit the screen size. Should I open a new task for that? It needs to be fixed asap, the watchlist is barely usable like this.

@XanonymusX - what browser/device are you on?

ovasileva updated the task description. (Show Details)Fri, Nov 1, 11:50 AM
ovasileva added a subscriber: Edtadros.

@Edtadros - tested on Chrome/Android and it looks great, but seems like we might have a problem with iOS based on T235414#5626146. Could you take a look on a couple of iOS devices?

Masumrezarock100 added a comment.EditedFri, Nov 1, 12:24 PM

@ovasileva I think I know what the problem is. Large edit summaries are not fitting in the screen properly. I was able to reproduce the same on my Android/Chrome Dev 79.



And this is happening with other Special pages not just Special:Watchlist.

XanonymusX added a comment.EditedFri, Nov 1, 1:11 PM

Yeah, in my case there were some very long web links in summaries. But even if I get rid of those, the initial buttons are still way too large (at least in German) for the screen size. I’m using iOS and testing it now on the smallest screen possible (I guess), on the iPod touch.

EDIT: Btw, the width problem occurs also on several other pages like the notifications page, so I guess this is a general issue with advanced mobile now?! Please do something about it asap.

EDIT: Btw, the width problem occurs also on several other pages like the notifications page, so I guess this is a general issue with advanced mobile now?! Please do something about it asap.

I am not so sure about the notification page, but definitely other Special pages are affected by this. Original MobileFrontend pages start long edit summaries and texts in a new line, while core counterparts don't.

ovasileva closed this task as Resolved.Mon, Nov 4, 9:56 AM

Thanks @XanonymusX and @Masumrezarock100 - opened T237230 to track this. Resolving this task for now.

ovasileva updated the task description. (Show Details)Mon, Nov 4, 9:57 AM