Page MenuHomePhabricator

Scale: VE in Serbian Wikipedia
Closed, ResolvedPublic

Description

We deployed the Growth features to Serbian Wikipedia in T241181: Deploy GrowthExperiments on Serbian Wikipedia. At that point, we realized that visual editor is not available for users in that wiki except for when they have explicitly enabled the preference. In addition to generally wanting Serbian users to have the visual editor, this matters for Growth features because our future plans (such as for guidance) expect that wikis will have visual editor available.

In this task, we want to look into the issues that are keeping visual editor from being available and decide if, when, and how to address them.

Relatedly, here is a link to a discussion on Serbian Wikipedia about whether users there want visual editor available.

Event Timeline

Restricted Application added a subscriber: Petar.petkovic. · View Herald TranscriptApr 21 2020, 11:36 PM

@ppelberg -- here is a task for us to discuss what it would take to make visual editor work on Serbian Wikipedia. It would be great if Editing engineers could add some notes about what exactly the issue is that the user experiences.

@Zoranzoki21 @Acamicamacaraca -- could you please summarize the results from your community conversation so far? Thank you!

Hello! I've started a discussion on village pump which is for technical things. In discussion some users opposed this idea, but arguments wasn't related to some problem with VisualEditor. The arguments were about buttons of editing options (for those who didn't enable VisualEditor).
Because for wiki which haven't VisualEditor, there is only button "Edit" (on Serbian Уреди). For wiki which have VisualEditor, enabled, option Edit means that page will be edited with VisualEditor, no with WikiEditor and that wiki have new button "Edit source (on Serbain Уреди извор) with which page can be edited with WikiEditor.

And I understand them. They are older, I understand that it may not have been easy for them to learn to contribute on Wikipedia.

But... I started "voting" three days ago, and currently 14 users are for and 2 aren't for this.

So, we should remove VisualEditor from beta options, but not enable it as default editor.

@Zoranzoki21: Heja, I'm afraid I don't fully understand (and I am only curious here - I am not involved in deploying VisualEditor): You describe that the "Edit" button either "starts" WikiEditor or VisualEditor, depending on the person's preferences and depending on the wiki which they are on. How does that create a problem?

(On mediawiki.org, VisualEditor is not listed under "Beta features". https://www.mediawiki.org/wiki/Special:Preferences#mw-prefsection-editing offers an "Editing mode"/"Режим уређивања" dropdown, and one option in that dropdown is "Show me both editor tabs"/"Прикажи картице оба уређивача". On https://sr.wikipedia.org/wiki/Посебно:Подешавања#mw-prefsection-editing there is no such dropdown, maybe because VE is still in beta on sr.wikipedia.org?)

@Zoranzoki21: Heja, I'm afraid I don't fully understand (and I am only curious here - I am not involved in deploying VisualEditor): You describe that the "Edit" button either "starts" WikiEditor or VisualEditor, depending on the person's preferences and depending on the wiki which they are on. How does that create a problem?

(On mediawiki.org, VisualEditor is not listed under "Beta features". https://www.mediawiki.org/wiki/Special:Preferences#mw-prefsection-editing offers an "Editing mode"/"Режим уређивања" dropdown, and one option in that dropdown is "Show me both editor tabs"/"Прикажи картице оба уређивача". On https://sr.wikipedia.org/wiki/Посебно:Подешавања#mw-prefsection-editing there is no such dropdown, maybe because VE is still in beta on sr.wikipedia.org?)

No. I told that "older users" thinks that this shouldn't be done, because they know that "edit" opens WikiEditor, no VisualEditor.
And that it will be hard for them to understand that "edit" will open VisualEditor, no WikiEditor. But we told that it will be possible for them to choose in settings behaviour which they want.

No worry. :) I believe that we will have consensus for removing VisualEditor from beta.

Okay, let's not complicate it. In short, we definitely have a consensus to get VE out of beta.

Single Edit Tab should not be enabled.

Restricted Application added a project: User-Zoranzoki21. · View Herald TranscriptApr 25 2020, 3:42 PM

Change 592455 had a related patch set uploaded (by Zoranzoki21; owner: Zoranzoki21):
[operations/mediawiki-config@master] Enable visualeditor on srwiki by default

https://gerrit.wikimedia.org/r/592455

Patch scheduled for Monday, April 27 European Mid-day SWAT.

@MMiller_WMF, @Tgr Is this okay for you?

Zoranzoki21 moved this task from Backlog to To deploy on the Serbian-Sites board.Apr 26 2020, 9:16 AM
Zoranzoki21 moved this task from Inbox to To deploy on the User-Zoranzoki21 board.

@Zoranzoki21 -- it's great that you and your community have moved swiftly and decisively on this! Do you know anything about these VE bugs we've heard about in srwiki, related to switching between scripts? I think we would want to know what kind of potential issues users would experience (and potentially solve them) before deploying.

I also think that members of the Editing team, such as @ppelberg and @Esanders should weigh in, which I think they will do in the next couple days. Therefore, I think it would be better to hold off on SWAT perhaps until a little later in the week. Is that okay?

@Zoranzoki21 -- it's great that you and your community have moved swiftly and decisively on this! Do you know anything about these VE bugs we've heard about in srwiki, related to switching between scripts? I think we would want to know what kind of potential issues users would experience (and potentially solve them) before deploying.

I also think that members of the Editing team, such as @ppelberg and @Esanders should weigh in, which I think they will do in the next couple days. Therefore, I think it would be better to hold off on SWAT perhaps until a little later in the week. Is that okay?

About switching between editor: Single Edit Tab won't be enabled, so users will just have two cards. For users which have VisualEditor enabled already, I think that nothing won't be changed. Everything is ok about it, I explained behaviour which will happen when we do this. And we have approval :).

So, I think that I shouldn't hold off deployment. If I (or someone else) find any kind of problem, I'll report it.

Thanks for help and understanding!

@Zoranzoki21 -- it's great that you and your community have moved swiftly and decisively on this!

+ 1

I also think that members of the Editing team, such as @ppelberg and @Esanders should weigh in, which I think they will do in the next couple days. Therefore, I think it would be better to hold off on SWAT perhaps until a little later in the week. Is that okay?

Thank you for the ping, @MMiller_WMF.

While we are not currently aware of any issues that we think should block this deployment, there are two questions (see below) related to LanguageConverter we'd like to answer before this config changed is deployed.

Questions
@Zoranzoki21, are you able to help us answer these two questions?

  1. Is sr.wiki aware of people encountering issues when using VE to edit an article in a Latin script when the underlying content is written in Cyrillic?
  1. If such issues exist, are you able to share a link to this/these issue(s) so we can experience them firsthand?

cc @cscott @dchan @Esanders @Whatamidoing-WMF

Questions
@Zoranzoki21, are you able to help us answer these two questions?

  1. Is sr.wiki aware of people encountering issues when using VE to edit an article in a Latin script when the underlying content is written in Cyrillic?

Umm, noone reported problem related to it with VisualEdtior.

  1. If such issues exist, are you able to share a link to this/these issue(s) so we can experience them firsthand?

I think that we haven't such issues.
@ppelberg

ppelberg added a comment.EditedApr 27 2020, 10:03 PM

Questions
@Zoranzoki21, are you able to help us answer these two questions?

  1. Is sr.wiki aware of people encountering issues when using VE to edit an article in a Latin script when the underlying content is written in Cyrillic?

Umm, noone reported problem related to it with VisualEdtior.

Understood.

  1. If such issues exist, are you able to share a link to this/these issue(s) so we can experience them firsthand?

I think that we haven't such issues.

I see, ok. Thank you for looking into this, @Zoranzoki21.

We are okay with this config change to enable VE as default on sr.wiki being deployed. [1]

If you become aware of any issues, please let us know.


  1. https://gerrit.wikimedia.org/r/#/c/operations/mediawiki-config/+/592455/
Zoranzoki21 added a comment.EditedApr 27 2020, 10:12 PM

Thanks @ppelberg! I scheduled patch for Evening SWAT. Sure, I will let you know if I find some problem.

Change 592455 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable visualeditor on srwiki by default

https://gerrit.wikimedia.org/r/592455

Mentioned in SAL (#wikimedia-operations) [2020-04-27T23:16:01Z] <catrope@deploy1001> Synchronized wmf-config/config/srwiki.yaml: Enable VisualEditor by default on srwiki (T250878) (duration: 00m 58s)

Mentioned in SAL (#wikimedia-operations) [2020-04-27T23:18:49Z] <catrope@deploy1001> Synchronized dblists/visualeditor-nondefault.dblist: Enable VisualEditor by default on srwiki (T250878) (duration: 00m 57s)

This is deployed, I can't find issues. Can we close this task as resolved?

Etonkovidova edited projects, added Growth-Team (Current Sprint); removed Growth-Team.

Thanks @Zoranzoki21 I checked it too - VE is removed from beta features and enabled by default for new users. Also I checked it for users who already had VE enabled - did not see any problems.

Moving it to PM column on our team work board so @MMiller_WMF may review it.

(On mediawiki.org, VisualEditor is not listed under "Beta features". https://www.mediawiki.org/wiki/Special:Preferences#mw-prefsection-editing offers an "Editing mode"/"Режим уређивања" dropdown, and one option in that dropdown is "Show me both editor tabs"/"Прикажи картице оба уређивача". On https://sr.wikipedia.org/wiki/Посебно:Подешавања#mw-prefsection-editing there is no such dropdown, maybe because VE is still in beta on sr.wikipedia.org?)

The options for Editing mode on https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-editing are not present on quite few wikis where VE is enabled by default. Maybe @ppelberg can provide some info why these options are not present on some wikis?

(On mediawiki.org, VisualEditor is not listed under "Beta features". https://www.mediawiki.org/wiki/Special:Preferences#mw-prefsection-editing offers an "Editing mode"/"Режим уређивања" dropdown, and one option in that dropdown is "Show me both editor tabs"/"Прикажи картице оба уређивача". On https://sr.wikipedia.org/wiki/Посебно:Подешавања#mw-prefsection-editing there is no such dropdown, maybe because VE is still in beta on sr.wikipedia.org?)

The options for Editing mode on https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-editing are not present on quite few wikis where VE is enabled by default. Maybe @ppelberg can provide some info why these options are not present on some wikis?

@Etonkovidova We haven't enabled Single Edit Tab. Maybe is it reason.

This is definitely the reason. Anyway, everything's fine for now.

@ppelberg -- I want to make sure you're good with all this, and that we've tied up the loose ends. If so, then we can resolve the task!

Zoranzoki21 added a comment.EditedApr 29 2020, 1:36 PM

One user asked a question on the village pump, so I'm asking it here.

He asked why VisualEditor enters <br/> when user press Enter to move in next line..

See: https://sr.wikipedia.org/wiki/Википедија:Трг/Техника#Нови_ред

@ppelberg -- I want to make sure you're good with all this, and that we've tied up the loose ends. If so, then we can resolve the task!

Thank you for the ping, @MMiller_WMF; I'd like to confirm the question below before closing this out...

Observation
Elena noticed the Editing mode preference on https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-editing are not present some wikis where VE is enabled by default.

Explanation
Zoran suggested this is expected behavior on sr.wiki because it uses two edit tabs.

Question
@matmarex, can you please confirm whether the behavior Elena observed is expected for the reason Zoran shared?

@ppelberg -- I want to make sure you're good with all this, and that we've tied up the loose ends. If so, then we can resolve the task!

Thank you for the ping, @MMiller_WMF; I'd like to confirm the question below before closing this out...

Observation
Elena noticed the Editing mode preference on https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-editing are not present some wikis where VE is enabled by default.

Explanation
Zoran suggested this is expected behavior on sr.wiki because it uses two edit tabs.

Question
@matmarex, can you please confirm whether the behavior Elena observed is expected for the reason Zoran shared?

Just confirmed the following with @Whatamidoing-WMF: the behavior Elena observed and Zoran explained is expected. See this page for more details: https://www.mediawiki.org/wiki/VisualEditor/Single_edit_tab.

@MMiller_WMF: you're good to close this out.

Everything is fine and in place. I hope a bug in the visual editor about adding <br> tags will be resolved.

MMiller_WMF closed this task as Resolved.May 1 2020, 12:08 AM

Thanks for making this happen @Zoranzoki21 and @Acamicamacaraca!

Thanks for making this happen @Zoranzoki21 and @Acamicamacaraca!

You're welcome! Good cooperation is very important.