Remove button for <big> from toolbar
Open, Stalled, LowestPublic

Description

In HTML5 <big> is deprecated, so I do not see any reason to have a button for it in the toolbar. The probably only reason why it is there is consistency with <small>, but since HTML5 isn't consistent in that point the toolbar needn't to be either.


Version: unspecified
Severity: normal
URL: http://www.w3.org/TR/2012/WD-html5-diff-20120329/#obsolete-elements

See also

Details

Reference
bz38487
bzimport raised the priority of this task from to Low.
bzimport set Reference to bz38487.
bzimport added a subscriber: Unknown Object (MLST).
Schnark created this task.Jul 19 2012, 9:02 AM

Instead of removing the button, its code could be changed to this:

'big': {
'labelMsg': 'wikieditor-toolbar-tool-big',
'type': 'button',
'icon': 'format-big.png',
'offset': [2, 2],
'action': {

		'type': 'encapsulate',
		'options': {
			'pre': "<span style=\"font-size: larger;\">",
			'periMsg': 'wikieditor-toolbar-tool-big-example',
			'post': "</span>"
		}

}

},

A gadget could try to do this until the bug is fixed, but

$( '#wpTextbox1' ).wikiEditor( 'removeFromToolbar', {
'section': 'advanced',
'group': 'size',
'tool': 'big'
} ).wikiEditor( 'addToToolbar', {
'section': 'advanced',
'group': 'size',
'tools': {

		'big': {
			'labelMsg': 'wikieditor-toolbar-tool-big',
			'type': 'button',
			'icon': 'format-big.png',
			'offset': [2, 2],
			'action': {
				'type': 'encapsulate',
				'options': {
					'pre': "<span style=\"font-size: larger;\">",
					'periMsg': 'wikieditor-toolbar-tool-big-example',
					'post': "</span>"
				}
			}
		}
        }

} );

would put the button in the wrong position...

(In reply to comment #2)

A gadget could try to do this until the bug is fixed

Here is another way:

// Workaround for [[bugzilla:38487]]
function fixBigButton(){

$( '.tool-button[rel=big]' )
  .off( 'click' )
  .on( 'click', function( e ){
    e.preventDefault();
    $( '#wpTextbox1' ).textSelection(
      'encapsulateSelection', {
        'pre': '<span style="font-size: larger;">',
        'peri': mw.msg( 'wikieditor-toolbar-tool-big-example' ),
        'post': '</span>'
      }
    );
  } );

}

if ( $.inArray( mw.config.get( 'wgAction' ), ['edit', 'submit'] ) !== -1 ) {

mw.loader.using( 'user.options', function () {
  if ( mw.user.options.get('usebetatoolbar') ) {
    mw.loader.using( [ 'jquery.textSelection', 'ext.wikiEditor.toolbar' ], function () {
      $( fixBigButton );
    } );
  }
} );

}

rahul14m93 wrote:

Gerrit Change #53010

Wikitext is not HTML. I'm not sure people actually want uglier wikitext.

(In reply to comment #5)

Wikitext is not HTML. I'm not sure people actually want uglier wikitext.

Indeed, this should probably be rejected: I suggest WONTFIX. (Sorry Rahul for the unclear status of this bug.)

For instance, I know some Wikimedia wikis where attempts at replacing simple markup with "more correct" HTML by bot were soundly and consistently rejected and forbidden. Wikis which want uglier wikitext can use Helder's solutions above, or bots.

rahul14m93 wrote:

(In reply to comment #6)

Its okay,i am happy to contribute in any form!

(In reply to comment #5)

[...] I'm not sure people actually want uglier wikitext.

My suggestion was to remove <big> completely, not to replace it with (I agree with you) ugly HTML. I can only see to reasons to user bigger font size than usual:

  • headlines, these should use == ... ==, not <big>
  • texts in other scripts that are hard to read in normal font size (like Arabic), these should have a lang="..." attribute, handle bidi correctly, etc. Adding some CSS to make them a bit bigger doesn't make things worse (it's inside a template in most cases anyway)

This seems to be not only my opinion: en.wikipedia adds a button for <small> to the old toolbar, but not one for <big> [1], the same is true for a gadget on de.wikipedia [2]

[1] [[MediaWiki:Common.js/edit.js]]
[2] [[de:Wikipedia:Helferlein/Extra-Editbuttons]]

Gerrit 53010

Change 53010 abandoned by Bartosz Dziewoński:
(Bug 38487) Replaced the <big> with <span> in jquery.wikiEditor.toolbar.config.js

Reason:
Per consensus on the bug.

https://gerrit.wikimedia.org/r/53010

TheDJ added a comment.Apr 7 2014, 5:27 PM
  • Bug 24488 has been marked as a duplicate of this bug. ***

On enwiki we replace <big> with the {{big}} template where appropriate. I have found instances where <big> should have never been used at all and the markup just needs to be removed.

{{big}} is defined as: <span style="font-size: 120%;">{{{1}}}</span>

GOIII added a subscriber: GOIII.Nov 27 2014, 7:14 AM
geraki added a subscriber: geraki.Mar 25 2015, 8:30 AM

Maybe it is possible for the parser to catch <big> in wikitext and render it as a <span> in HTML?
No ugly wikitext, no templates, faster parsing, better semantics.

He7d3r updated the task description. (Show Details)Apr 17 2015, 7:25 PM
He7d3r set Security to None.
EoRdE6 added a subscriber: EoRdE6.Apr 17 2015, 8:23 PM

I brought this up on the en.wiki village pump not knowing this was here. I think it would be a simple fix to use either {{big}} or the span style that it uses.

EoRdE6 added a comment.May 9 2015, 9:19 PM

@Technical13 Well past Sunday, any word on how this is coming along (or not?) No hurry, just curious.

Sorry @EoRdE6, still trying to wrap my head around the consensus. It looks like the consensus is to just completely remove the ability to make text bigger. The alternative might be to add support for big tags as an xml object. Not sure if I want to do that either. Have to think about it a little more.

Bugreporter removed Technical13 as the assignee of this task.Jul 30 2015, 5:59 AM
Bugreporter added a subscriber: Bugreporter.

This user (Technical 13) is retired from Wikimedia. (feel free to reclaim it)

Danny_B raised the priority of this task from Low to Normal.
NeerajBattan rescinded a token.

Change 271949 had a related patch set uploaded (by Haritha28):
Remove button <big> from toolbar

https://gerrit.wikimedia.org/r/271949

Haritha28 moved this task from Backlog to Doing on the Easy board.Feb 21 2016, 5:30 AM
Danny_B assigned this task to Haritha28.Mar 10 2016, 9:02 AM
Stigmj added a subscriber: Stigmj.Mar 18 2016, 4:02 PM
Perhelion rescinded a token.
Perhelion added a subscriber: Perhelion.
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptJul 8 2016, 10:36 PM

Change 340515 had a related patch set uploaded (by Amritsreekumar):
[mediawiki/extensions/WikiEditor] Remove button for <big> from toolbar

https://gerrit.wikimedia.org/r/340515

Change 340515 abandoned by Amritsreekumar:
Remove button for <big> from toolbar

https://gerrit.wikimedia.org/r/340515

Change 340518 had a related patch set uploaded (by Amritsreekumar):
[mediawiki/extensions/WikiEditor] Remove button for <big> from toolbar

https://gerrit.wikimedia.org/r/340518

Jdforrester-WMF lowered the priority of this task from Normal to Lowest.Mar 21 2017, 10:05 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Though <big> is not valid HTML it's valid wikitext. Re-writing <big>s in the parser into <span style…> is an option being considered in T154067 but whether or not that's done I don't think we're likely to want to do this any time soon. Maybe in another three or four years' time once TemplateStyles (or whatever) is everywhere.

Change 340518 abandoned by Jforrester:
Remove button for <big> from toolbar

Reason:
Sorry, have followed-up on the task explaining that this isn't appropriate to do now.

https://gerrit.wikimedia.org/r/340518

Change 271949 abandoned by Jforrester:
Remove button <big> from toolbar

Reason:
Sorry, have followed-up on the task explaining that this isn't appropriate to do now.

https://gerrit.wikimedia.org/r/271949

Dropping "Easy" because that implies that newbies should take on this task, which is grossly inappropriate. :-)

Perhelion changed the task status from Open to Stalled.Mar 30 2017, 9:11 AM

Perhelion changed the task status from "Open" to "Stalled".

How is this report stalled? What information is missing?

Perhelion added a comment.EditedMar 30 2017, 10:35 PM

How is this report stalled? What information is missing?

Simply by information from @Jdforrester-WMF !?

I don't think we're likely to want to do this any time soon. Maybe in another three or four years' time once...

Change 271949 abandoned by Jforrester: ...this isn't appropriate to do now.

If I miss something you can correct me.

Nemo_bis closed this task as Declined.Mar 31 2017, 9:43 AM

Ok. If your intention was to change the status to

Maybe in another three or four years' time

then, in absence of our traditional RESOLVED LATER, the relevant status is "declined".

Jdforrester-WMF reopened this task as Stalled.Apr 1 2017, 3:47 PM

This task does not meet the guidance in https://www.mediawiki.org/wiki/Bug_management/Bug_report_life_cycle for "Declined", as I am not vetoing it for all time as the product owner, I do not think it necessarily "contradicts a particular project's scope or the principles of the project", and I don't think either that "consensus that implementing [this request] would be a bad idea".

However, it clearly does meet the standard for "Stalled". Specifically, it is waiting for further input on a non-Phabricator task (review by the relevant product owner in a few years' time), as I mentioned, and cannot be acted upon until that happens.

Nemo, I know the "Stalled" status is a pet peeve of yours, but this attitude is not helpful. :-(

Nemo_bis removed a subscriber: Nemo_bis.Apr 1 2017, 7:07 PM

I've updated the example at
https://www.mediawiki.org/wiki/Extension:WikiEditor/Toolbar_customization?diff=2705521#Removing_things
to illustrate how to remove this button from enhanced edit toolbar.

Izno added a subscriber: Izno.Jun 29 2018, 12:36 PM
Perhelion added a comment.EditedSun, Aug 26, 7:57 AM

Not that this is an important button, but the general problem is, the Wiki syntax is intended to be a tag language and HTML developing is going straight to favor CSS. And so Wikimedia don't want CSS in syntax: T37704

So there is no real reason the remove such tags from Wiki syntax, compare the center tag, which is deprecated since over 20 years in HTML, but really widely used (in relation to deprecation, in some lesser strict Wikis, I self rreplaced hundreds of them).