Page MenuHomePhabricator

Invalid HTML markup standalone LI element when using references on main page
Closed, ResolvedPublic

Description

  • Visit main page in edit mode (append action=edit at the end)
  • Enter text <ref>boo</ref>
  • Save

With the Cite extension enabled this renders a standalone <li> tag without a parent <ol class="references"> tag.


Version: unspecified
Severity: normal

Details

Reference
bz71023

Related Objects

Event Timeline

bzimport raised the priority of this task from to Needs Triage.
bzimport set Reference to bz71023.
bzimport added a subscriber: Unknown Object (MLST).

Actually this appears to be a problem with the Cite extension.

The same problem happens on desktop.

Output is:
<li id="cite_note-1"><span class="mw-cite-backlink"><a href="#cite_ref-1"><span class="cite-accessibility-label">Jump up </span>↑</a></span> <span class="reference-text">boo</span>
</li>
without parent ol or ul tag.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 9 2015, 8:12 PM
Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptDec 10 2015, 11:00 PM
phuedx added a subscriber: phuedx.Mar 30 2016, 10:47 AM

I can't reproduce this locally. I'm using MediaWiki-Vagrant (634ca6a) and mediawiki-extensions-Cite (d4b435a).

@Jdlrobson: Can you confirm that you're still seeing this bug?

Izno moved this task from Unsorted backlog to Defect backlog on the Cite board.Aug 22 2016, 6:42 PM
Jdlrobson closed this task as Resolved.Jul 13 2017, 6:53 PM
Jdlrobson claimed this task.

Seems fixed to me.