Page MenuHomePhabricator

Edit warnings have escaped HTML
Closed, ResolvedPublic

Event Timeline

matmarex updated the task description. (Show Details)Oct 29 2016, 3:06 PM
Urbanecm triaged this task as Unbreak Now! priority.Oct 29 2016, 9:45 PM

UBN as this breaks almost all filters at cswiki with warn. At least a revert of mentoined change.

Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes. · View Herald TranscriptOct 29 2016, 9:45 PM

The only recent change to AbuseFilter is

rEABFb31d903900f62972b8a1e74f8c2b7dc6b80a44a5

rEABF0309113bd98b3cb68d3d996682606ea4b5927559

Did this only recently happen?

Like last week or the week before?

Change 318770 had a related patch set uploaded (by Paladox):
Revert "EditPage: Show EditFilterMergedContent hook errors in an errorbox"

https://gerrit.wikimedia.org/r/318770

Dereckson updated the task description. (Show Details)Oct 29 2016, 9:58 PM

Change 318772 had a related patch set uploaded (by Paladox):
Revert "EditPage: Show EditFilterMergedContent hook errors in an errorbox"

https://gerrit.wikimedia.org/r/318772

Change 318772 merged by jenkins-bot:
Revert "EditPage: Show EditFilterMergedContent hook errors in an errorbox"

https://gerrit.wikimedia.org/r/318772

Mentioned in SAL (#wikimedia-operations) [2016-10-29T22:26:43Z] <reedy@tin> Synchronized php-1.28.0-wmf.23/includes/EditPage.php: Fix for T149473 (duration: 00m 49s)

Reedy lowered the priority of this task from Unbreak Now! to High.Oct 29 2016, 10:27 PM
Peachey88 updated the task description. (Show Details)Oct 30 2016, 6:31 AM

Adding a reminder: i18n messages were not reverted, so those should be cleaned-up before this task is closed, if there won't be a fix that re-uses them.

Change 318983 had a related patch set uploaded (by Thcipriani):
Revert "EditPage: Show EditFilterMergedContent hook errors in an errorbox"

https://gerrit.wikimedia.org/r/318983

Change 318983 merged by jenkins-bot:
Revert "EditPage: Show EditFilterMergedContent hook errors in an errorbox"

https://gerrit.wikimedia.org/r/318983

I am confused by the patches here. This has been backported to 1.28 and 1.28.0-wmf.23, but not merged into master. So it will regress again this week when 1.29.0-wmf.1 is deployed? https://gerrit.wikimedia.org/r/#/q/I35a650c6ec478542351824e8ae8a8d8354ffa50f

matmarex added a subscriber: Reedy.Nov 2 2016, 12:17 PM

@Reedy It seems you deployed this to 1.28.0-wmf.23 (according to SAL). Why is it not merged in master or 1.29.0-wmf.1?

matmarex raised the priority of this task from High to Unbreak Now!.Nov 2 2016, 12:17 PM

@Reedy It seems you deployed this to 1.28.0-wmf.23 (according to SAL). Why is it not merged in master or 1.29.0-wmf.1?

I hoped Lego was going to get it fixed before. However, it was known it wasn't... It was discussed with @thcipriani about merging, and/or cherry picking to .1

I'm not sure what actually happened (aka I'm not running the train)

Will deal with now

Change 319309 had a related patch set uploaded (by Reedy):
Revert "EditPage: Show EditFilterMergedContent hook errors in an errorbox"

https://gerrit.wikimedia.org/r/319309

Change 319309 merged by jenkins-bot:
Revert "EditPage: Show EditFilterMergedContent hook errors in an errorbox"

https://gerrit.wikimedia.org/r/319309

Change 318770 merged by jenkins-bot:
Revert "EditPage: Show EditFilterMergedContent hook errors in an errorbox"

https://gerrit.wikimedia.org/r/318770

Mentioned in SAL (#wikimedia-operations) [2016-11-02T12:32:03Z] <reedy@tin> Synchronized php-1.29.0-wmf.1/includes/EditPage.php: Fix regression from 1.28.0-wmf.23 T149473 (duration: 00m 47s)

Reedy lowered the priority of this task from Unbreak Now! to Normal.Nov 2 2016, 12:37 PM
matmarex closed this task as Resolved.Nov 2 2016, 3:24 PM
matmarex assigned this task to Reedy.

Now merged and deployed everywhere that it should be.

@Reedy It seems you deployed this to 1.28.0-wmf.23 (according to SAL). Why is it not merged in master or 1.29.0-wmf.1?

I hoped Lego was going to get it fixed before. However, it was known it wasn't... It was discussed with @thcipriani about merging, and/or cherry picking to .1

Yes. I cherry-picked this change to REL1_28, but missed cherry-picking the change to master before the 1.29.0-wmf.1 branch cut, my fault completely, sorry :(

Nikerabbit reopened this task as Open.Nov 2 2016, 7:39 PM

Adding a reminder: i18n messages were not reverted, so those should be cleaned-up before this task is closed, if there won't be a fix that re-uses them.

Base added a subscriber: Base.Nov 3 2016, 4:01 PM
mmodell added a subscriber: mmodell.Nov 3 2016, 6:09 PM

I'm removing this from blocking T149059: MW-1.29.0-wmf.1 deployment blockers since the only thing remaining is cleanup which shouldn't block the train.

Change 323175 had a related patch set uploaded (by Bartosz Dziewoński):
Remove unused messages

https://gerrit.wikimedia.org/r/323175

Change 323175 merged by jenkins-bot:
Remove unused messages

https://gerrit.wikimedia.org/r/323175

matmarex closed this task as Resolved.Nov 25 2016, 1:58 PM
matmarex removed a project: Patch-For-Review.

Change 406309 had a related patch set uploaded (by Anomie; owner: Anomie):
[mediawiki/core@master] Revert and fix "Revert "EditPage: Show EditFilterMergedContent hook errors in an errorbox""

https://gerrit.wikimedia.org/r/406309

Change 406309 merged by jenkins-bot:
[mediawiki/core@master] Revert and fix "Revert "EditPage: Show EditFilterMergedContent hook errors in an errorbox""

https://gerrit.wikimedia.org/r/406309