Make ULS input methods work in content editable divs of VisualEditor
Closed, ResolvedPublic40 Story Points

Details

Blocks
T57972: VE cursor test invokes ULS IME in Firefox on test2wiki
T84936: Release VisualEditor-MediaWiki as "1.0"
T35077: VisualEditor multilingual input / i18n issues (tracking)
T55014: Input Methods issues for supported languages (tracking)
Blocked By
T56283: VisualEditor: Cursor jumps to the beginning of the sentence/paragraph when using jquery.IME
T121216: jQueryIME: If contentEditable cursor not in a text node, then insertion goes before the first CE text character
T56424: VisualEditor: Automatic Incorrect caret movement with ULS
T56421: VisualEditor: Text duplication when using jquery.IME on existing pages
T56334: VisualEditor: "Uncaught TypeError: Cannot call method 'getOffset' of null" triggered using jquery.IME
T56331: VisualEditor: "Uncaught Error: ve.dm.Document.getNodeFromOffset(): offset 804 is out of bounds" triggered using jquery.IME
T55788: VisualEditor: Marathi/Devanagari: Save button does not get enabled for same or lesser length change
T55758: Visualditor: Marathi/Devanagari: edit change not reflecting in edit preview
T55757: VisualEditor: Marathi/Devanagari: Backpace deletes text on right side
T55754: VisualEditor: Implement script-specific cursoring for Devanagari if native cursoring is insufficient
T55711: VisualEditor: Cursor cannot move through text created with jquery.IME when editing bulleted text
T55708: VisualEditor: Incorrect and irremovable text placement with IMEs
T55706: VisualEditor: Incorrect text selection with jquery.IME
T55705: VisualEditor: Content disappears when using jquery.IME
T55701: VisualEditor: Marathi/Devanagari: After typing first character cursor moves in wrong direction when using jquery.IME
T55700: VisualEditor: When using jquery.IME, type a word and press space bar = eliminates typed text immediately
Reference
bz49569
Vssun created this task.Jun 14 2013, 9:12 AM

This is part of a GSOC2013 project and tracked here https://github.com/wikimedia/jquery.ime/issues/136

  • Bug 49643 has been marked as a duplicate of this bug. ***

CCing Moriel who's working for GSoC2013 on VisualEditor issues around i18n and in particular RTL; she may have some thoughts. :-)

  • Bug 49704 has been marked as a duplicate of this bug. ***
  • Bug 50293 has been marked as a duplicate of this bug. ***

Making this a bug instead of a feature, as we would expect the key mappings to work on any input field that is more or less supported for well supported and stable MediaWiki extensions, including VisualEditor.

Set to highest priority. Tracked on Wikimedia Language Engineering team as https://mingle.corp.wikimedia.org/projects/internationalization/cards/3493

If anyone is working on this and expects to be done before 2013-07-07, please let us know and we'll wait. Otherwise, I expect we will have development capacity to take this up and get it delivered by 2013-07-09.

  • Bug 50345 has been marked as a duplicate of this bug. ***

ansumang wrote:

Santhosh, I think by changing the summary, we could avoid the duplicates?

(In reply to comment #7)

> *** Bug 50345 has been marked as a duplicate of this bug. ***

  • Bug 51354 has been marked as a duplicate of this bug. ***

Hi,

Waiting for this to be available for test,if possible couple of days before VE to be launched on vernacular wikis which are dependent on ULS. Time table for hi and few other wikis is expected to be 22nd July 2013.

Thanks and Warm Regards

It's probably important to manage expectations here.

Tl;dr: it's not realistic to assess that ULS/jQuery.IME input methods will work in VE before the end of July 2013. At this time, no reliable estimate can be made when this is to be expected. Working towards getting this issue resolved has a high priority in the VE and LE teams.

Input methods for many scripts, either natively supported by an operating system, by an application, or by JavaScript, are currently incompatible or at least lead to unexpcted behavior when using VisualEditor.

Possible ways that will allow this to be resolved are currently being explored. I expect that by the end of next week, The VisualEditor and Language Engineering team will have an understanding that will allow them to estimate how much time is needed to make native input possible in most, if not all scripts, when using VE. Once that is done, further exploration is needed to assess the effort needed to make input methods work correctly, including the input methods of ULS/jQuery.IME.

See bug 33077 for more details. In the near future, I expect we will be able to identify issues that need to be resolved before we can work on this issue specifically in the field "depends on".

Hi,

Thanks for your reply,I know in any case you will be doing your best to make both extensions compatible.What will be likely situation during the time gap,so please let we know if you can think of any easy time gap solution can be made available.Other wise even while ULS is with us, we will be back to square one.

Warm Regards

With https://gerrit.wikimedia.org/r/#/c/79755/ jquery.ime start working in visual editor. The UI is not integrated well with the VE UI. And there are VE specific bugs related to cursor handling and text selection, that are applicable to all IMEs or non latin text.

(In reply to comment #13)
@ Santhosh Thottingal Please have a look at [https://en.wikipedia.org/wiki/Wikipedia:VisualEditor/Feedback#VE_.2B_ULS_unicode_Devnagari_Script_input_issues].I have added a table of known issues today.

Rgds

Please use bugzilla as the single place o make issues known that are relevant for developers. References to lists of issues on wiki pages will not do.

  • Bug 58662 has been marked as a duplicate of this bug. ***
Jdforrester-WMF changed the title from "Make ULS input methods work in content editable divs of Visual Editor" to "Make ULS input methods work in content editable divs of VisualEditor".
Jdforrester-WMF removed dchan as the assignee of this task.
Jdforrester-WMF lowered the priority of this task from "High" to "Normal".Jan 9 2015, 10:55 PM
Restricted Application added a project: Notice. · View Herald TranscriptMar 30 2015, 11:29 PM
gpaumier moved this task from Backlog to Triaged on the Notice board.Apr 2 2015, 6:30 PM
gpaumier moved this task from Triaged to Archive on the Notice board.Apr 2 2015, 7:00 PM
Jdforrester-WMF moved this task from June 2015 to Not soon on the Roadmap board.Jun 4 2015, 4:04 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 21 2015, 6:30 PM
mxn added a subscriber: mxn.Jul 22 2015, 2:15 AM

As of https://gerrit.wikimedia.org/r/#/c/264577/ in MediaWiki-extensions-UniversalLanguageSelector this should now be resolved and working for all users, and will be part of the wmf.12 release starting tomorrow.

Jdforrester-WMF closed this task as "Resolved".Jan 25 2016, 7:17 PM
Jdforrester-WMF assigned this task to dchan.
KuboF awarded a token.Feb 6 2016, 4:46 PM
KuboF removed a subscriber: KuboF.

Add Comment