Move first paragraph before infobox on stable
Closed, ResolvedPublic1 Story Points

Description

NOTE: currently blocked by quicksurveys. Do not deploy before May 23

Story
As a reader, I want the ability to get an overview of an article as soon as I land on the page, so I do not have to scroll very far to know what the article is about
Acceptance Criteria
This is now on beta, implemented in T145216: MobileFormatter should relocate first paragraph ahead of infobox. Move to stable on all projects.

  • Subtasks are all resolved
  • There is a decrease in the amount of unusual infoboxes being logged after we have deployed (T163805)
  • Enabled on stable and beta

Ensure before signoff

Additional notes
The Mobileview api is not impacted because ->filterContent does not apply any of the optional transformations including the lead paragraph transformation.

Testing Criteria

  1. Visit https://en.m.wikipedia.org/wiki/U.S._Route_113 as a logged in/logged out user on a mobile device
  2. Ensure lead paragraph appears before infobox
  3. Turn on beta mode
  4. Ensure lead paragraph appears before infobox

Also test on the following pages:
https://en.m.wikipedia.org/wiki/Planet (for testing lists)
https://en.m.wikipedia.org/wiki/List_of_micronations (no infobox, list article)
https://he.m.wikipedia.org/wiki/%D7%94%D7%9E%D7%90%D7%94_%D7%94-14 (rtl)
https://bg.m.wikipedia.org/wiki/15_%D0%B2%D0%B5%D0%BA_%D0%BF%D1%80.%D0%BD.%D0%B5. (no first paragraph expected)
https://bg.m.wikipedia.org/wiki/%D0%A1%D0%B5%D0%BB%D0%B4%D0%B6%D1%83%D0%BA%D0%B8 (image instead of infobox)
https://en.m.wikipedia.org/wiki/Barack_Obama

Related Objects

There are a very large number of changes, so older changes are hidden. Show Older Changes
ovasileva set the point value for this task to 1.Apr 11 2017, 4:33 PM
Restricted Application added a subscriber: Dereckson. · View Herald TranscriptApr 13 2017, 6:57 PM

It's blocked by T162713 and any tasks created as a result of that spike.

Jdlrobson updated the task description. (Show Details)Apr 27 2017, 12:13 AM
Jdlrobson updated the task description. (Show Details)May 1 2017, 10:44 PM
Jdlrobson moved this task from Upcoming to Triaged but Future on the Readers-Web-Backlog board.
Jdlrobson added a subscriber: Jdlrobson.

@ovasileva when deploying this, we cannot do a 90% rollout (not possible) without an A/B test infrastructure. Is looking at the ReadingDepth before and after the change sufficient to determine whether we can rollout.

Jdlrobson updated the task description. (Show Details)May 2 2017, 7:04 PM

We're ready to deploy this when you are @ovasileva
I've purposely put this in the current sprint so please don't add it. We can talk about why when you get back.

Jdlrobson updated the task description. (Show Details)May 2 2017, 11:55 PM
ovasileva updated the task description. (Show Details)

@ovasileva We now know that the reader surveys won't finish by May 22. I discussed this with the team and we think it makes sense for us not to create a blocker for the deployment of this task for the following two reasons:

  • If a change like this changes the result we see in enwiki significantly (compared to what we saw last year), we have a bigger problem. ;)
  • We think that the bias correction should take care of the potential impact this change can bring.

With this, I propose that you go ahead and deploy the change. If you can deploy the change between May 16 and May 22, that'd be ideal. If not, just let us know and we will delay the main surveys as needed. And to be clear: this is just a suggestion, please don't rush on our account, just let us know your timelines.

Question: when this task is finalized, where should we expect to see the QS widget? After the lead paragraph but before the infobox? or after the lead paragprah and the infobox?

Thanks for your help.

@leila - Thank you, that sounds good! I'm currently double checking some things in terms of evaluation, but I believe we can deploy before May 22. I'll let you know if there's any blockers. Do you know what the current date is for the survey to go out?

Tbayer added a subscriber: Tbayer.May 17 2017, 3:23 PM
leila added a subscriber: schana.May 17 2017, 4:35 PM

@ovasileva we've run into a problem that was identified after the tests we did on Monday and that is clientIp is not being collected for events after T128407 was deployed. @schana is working with Analytics to address this. @schana can you give us a sense of by when you expect the clientIp issue to be resolved?

@ovasileva after the issue is resolved, we need to run another test, most probably, to test the data collection (we can do very little without the IP address to test the data) and only after that we can start the real surveys. So it's safe to say we need at least another week before pushing out the surveys.

Jdlrobson updated the task description. (Show Details)May 17 2017, 5:33 PM
schana added a comment.EditedMay 21 2017, 11:30 AM

@ovasileva we've run into a problem that was identified after the tests we did on Monday and that is clientIp is not being collected for events after T128407 was deployed. @schana is working with Analytics to address this. @schana can you give us a sense of by when you expect the clientIp issue to be resolved?

The issue was resolved here: T165678

ovasileva updated the task description. (Show Details)May 21 2017, 1:10 PM
ovasileva updated the task description. (Show Details)
ovasileva removed ovasileva as the assignee of this task.
phuedx moved this task from To Do to Doing on the Readers-Web-Kanban-Board board.May 24 2017, 9:02 AM
phuedx claimed this task.

Change 355397 had a related patch set uploaded (by Phuedx; owner: Phuedx):
[operations/mediawiki-config@master] mobileFrontend: Move first paragraph before infobox

https://gerrit.wikimedia.org/r/355397

ovasileva updated the task description. (Show Details)May 24 2017, 5:47 PM
ovasileva updated the task description. (Show Details)May 24 2017, 6:05 PM

Change 355397 merged by jenkins-bot:
[operations/mediawiki-config@master] mobileFrontend: Move first paragraph before infobox

https://gerrit.wikimedia.org/r/355397

phuedx updated the task description. (Show Details)May 24 2017, 6:29 PM
phuedx updated the task description. (Show Details)

Mentioned in SAL (#wikimedia-operations) [2017-05-24T18:31:02Z] <thcipriani@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:355397|mobileFrontend: Move first paragraph before infobox]] T150325 (duration: 00m 41s)

Additional notes
The Mobileview api is not impacted because ->filterContent does not apply any of the optional transformations including the lead paragraph transformation.

@Jdlrobson double checked this on mwdebug1002 before the change was deployed the wikis.

phuedx added a comment.EditedMay 24 2017, 6:37 PM

Dashboards to keep an eye on:

So far so good on the logs but i want to keep an eye on it a little longer.

@leila - this is now deployed on all projects, let us know if there's any issues in relation to the survey launch!

ovasileva updated the task description. (Show Details)May 25 2017, 10:23 AM
ovasileva closed this task as Resolved.

all done! Looks pretty great too.

phuedx updated the task description. (Show Details)May 25 2017, 11:19 AM

So far so good on the logs but i want to keep an eye on it a little longer.

I double checked the logs and I don't see anything new.

phuedx updated the task description. (Show Details)May 25 2017, 11:32 AM

There is a decrease in the amount of unusual infoboxes being logged after we have deployed (T163805).

^ That was a bit premature. There's been a noticeable increase of "Found wrapped infobox" log messages in the last 24h. However, this is to be expected as we just opened up the feature to a much wider audience.

@Jdlrobson: Should we turn the logging off now that we have a large set of examples?

BTW this doesn't seem to work on https://en.m.wikipedia.org/wiki/Battle_of_Mosul_(2016%E2%80%9317) right now - on my phone, I need to scroll through about 6 screens of infobox before the first sentence of the introduction appears.