Page MenuHomePhabricator

Option to disable notifications about 1st, 10th, etc. edit ("You made your <milestone> edit!")
Open, Needs TriagePublic

Description

When I make my 1st, 10th, 100th, 1000th edit on a wiki, I get a notification congratulating me. There is no option to switch this off in Special:Preferences. Please add such an option. As a steward, new wikis importer and whatnot I often edit a lot of Wikimedia wikis and constantly get these meaningless notifications. Thanks.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 6 2017, 8:47 PM
Legoktm removed a subscriber: Notifications.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJul 6 2017, 8:48 PM
Nikki added a subscriber: Nikki.Jul 11 2017, 6:21 PM

How is this blocked on global preferences? I'd say the first step would be
having a preference for this at all, then it could at least be set
individually, e.g. after getting the first such notification.

Alsee added a comment.Oct 22 2017, 2:33 AM

@Aklapper I'm not sure how to handle this. T178735 was merged here because it addresses the same issue, but I disagree with the task being proposed here. This is task is defined as a child of Support global preferences. Should I alter the task tile & description to address the problem in general?

A local preference would be pointless, having to fiddle with preferences to block the next two or three notifications.
A global preference would have the intended effect, however this is a pretty crummy item to spam onto an already cluttered preference list. This approach also means nothing can be done until global preferences are built.

A better fix would be to base the feature on global edit count. That would apply the intended rate limit for these notifications.

In my opinion the best fix would be just to eliminate these notifications. They are a useless annoyance. It lowers my opinion of a website when I encounter this sort of thing. It's condescending to have a zero-IQ chat-bot interrupt whatever I'm doing, to pat me on the head for reaching 1/10/100 edits.

Should I alter the task tile & description to address the problem in general?

No, you'd argument for your points instead.

I'm not sure how to handle this.

Me neither.

A better fix would be to base the feature on global edit count. That would apply the intended rate limit for these notifications.

That wouldn't solve the entire complexity of it all.

In my opinion the best fix would be just to eliminate these notifications. They are a useless annoyance. It lowers my opinion of a website when I encounter this sort of thing. It's condescending to have a zero-IQ chat-bot interrupt whatever I'm doing, to pat me on the head for reaching 1/10/100 edits.

Many people like to know statistics about themselves.
Wikimedians have been tracking editcount since the dawn of it all.
At Enwiki alone, we have five essays, a wikiproject (listing dozens of tools), over a dozen (listed) templates, and it's one of the most common aspects on userpages. https://en.wikipedia.org/wiki/Wikipedia:Edit_count#See_also

This is why "badges" are a thing, in various areas of life. E.g. Stackexchange goes strongly into them (random example: https://unix.stackexchange.com/users/7453/slm?tab=badges ) - I think some of those are silly, and some are interesting.
This is part of why people set milestones in work projects, and use fitness trackers, and etc.
Some people don't appreciate them, or not in all circumstances (e.g. someone may like to be told their statistics/given badges on Steam, but not on Stackexchange or Wikimedia).
They can cause some people to be annoyed, if they don't appreciate the value that others see in the feature.
Not all features will make 100% of users happy, and some will have unavoidable drawbacks of varying sizes.
It is not helpful to demean everyone who does like a system or who works on that system. (Your last paragraph implicitly demeans anyone who finds these notifications to be motivating or gives them a smile.)

However, I agree with MF_Warburg that it can be slightly annoying to everyone, to get these notifications at many wikis. This is primarily an issue encountered for cross-wiki maintainers/testers, i.e. people who regularly make around a dozen edits at many wikis (thus hitting the first two milestones). It would be good to fix this feature, to mitigate this edge-case. E.g. perhaps something like "Once a user has 10 "first edit" notifications and 5 "tenth edit" notifications, no more are sent" (that would cover people who want/appreciate them and who edit an entire language's sister projects, and resolve the edge-case of editors who edit a vast number ofwikis).

Alsee added a comment.Nov 1 2017, 11:27 AM

@Quiddity I don't understand what you mean [using global edit count] wouldn't solve the entire complexity of it all. Are you saying that wouldn't generate enough notifications? Or are you saying there's some technical problem? Or something else?

Many people like to know statistics about themselves - sure. I'm not objecting to statistics pages. The concern is push notifications. I have thousands of edits. When I make an edit on some random wiki, it is extremely unhelpful to interrupt my work with a notification telling me I made a first edit.

Aklapper renamed this task from Option to disable notifications about 1st, 10th, etc. edit to Option to disable notifications about 1st, 10th, etc. edit ("You made your <milestone> edit!").Nov 19 2017, 9:46 PM
Stryn added a subscriber: Stryn.Nov 20 2017, 7:07 PM

This notification should just be removed as discussed in T160446. It's annoying to cross-wiki editors and actually has a negative effect on editing behavior per https://meta.wikimedia.org/wiki/Research:Post-edit_feedback/PEF-2.

So should this task be closed as declined, in favor of T160446: Kill the edit threshold notifications (other than 1st)?

robkam added a comment.EditedDec 11 2017, 2:48 PM

Entirely killing it (including the 1st) would be the better option. However T160446 is declined and closed.

We classified this as being blocked by global preferences for the following reason: on any given wiki, there are only 4 or so notifications that you will ever get that are caused by this feature. So it seemed unlikely that @MF-Warburg was suggesting we create a whole apparatus so as not to be bothered by 4 notifications.

Our assumption was that the proposed feature is of interest to people who edit across wikis, and are tired of getting "congratulations on your first edit in Slovakian" messages every time they jump into a new project to make a change. Because that can, in fact, happen a lot to border-hopping editors.

Said border hoppers are unlikely to preemptively change preferences before making edits on every new wiki they visit, so this seemed like a feature that would be useful only if we had global preferences.

So that was the thinking. What are we missing?

@jmatazzoni: It seems to me that there's an easy way to solve this problem without having to mess with preferences. The basic issue is that this notification is only really useful (if it's useful at all) on your home wiki. People who edit multiple (and in some cases, hundreds of) different wikis aren't newbies and they will only view these notifications as annoying, especially after the 100th or 200th one. For example, I've made at least 1 edit on over 100 wikis and I don't even consider myself a super active editor. The solution would be to only generate these notifications on your home wiki, i.e. if the wiki you're editing isn't your home wiki, don't even generate these notifications at all. That way they will still serve their intended purpose (encouraging newbie) and they won't annoy the old-timers :)

@jmatazzoni: It seems to me that there's an easy way to solve this problem without having to mess with preferences. The basic issue is that this notification is only really useful (if it's useful at all) on your home wiki.

This is based on assumptions that aren't true. The "home" wiki doesn't mean anything for the majority of accounts. Also, as counter-examples, much of the positive feedback we've got is from people noting reaching thresholds on wikis that are traditionally not your first (like Commons and Wikidata).

Stryn added a comment.Dec 12 2017, 9:07 PM

All this kind of notifications (including the new filters for edit review's "welcome window", content translation popups) are very annoying for us who are working on every wikis (for example stewards, global sysops and other SWMT members). We should have an option to disable those at all or only show them once, not in every wikis we visit. I can't say anything positive things of those, sorry.

In T169924#3832434, @Stryn wrote:

...We should have an option to disable those at all or only show them once, not in every wikis we visit.

Yes, that would be great. I understand. If I'm not mistaken, however, the problem once again is that this is not possible because we don't have T16950—which would be a significant effort.

This is based on assumptions that aren't true.

You're correct. My assumption is that this notification is helpful to newbies and not helpful to old-timers. According to the only data we have, it's probably helpful to neither. I do know from personal and anecdotal evidence that at least some users find this notification annoying and spammy. For example, you can easily edit dozens of different wikis just by moving a single file on Commons.

An alternate (but much more complicated) idea would be to only send notifications for your 1st, 10th, 100th edit across all wikis rather than each wiki separately.

Otherwise, GlobalPreferences is coming soon. It's been stalled by RfCs (T178449), but I anticipate it will be available in the first half of next year.

Is there any progress on this? Would be much appreciated.

Restricted Application added a project: Growth-Team. · View Herald TranscriptAug 7 2018, 1:23 PM
JTannerWMF moved this task from Inbox to To Triage on the Growth-Team board.Aug 9 2018, 6:13 PM
JTannerWMF moved this task from To Triage to Triaged but Future on the Growth-Team board.
JTannerWMF moved this task from Triaged but Future to To Triage on the Growth-Team board.

We are going to wait a little bit as we continue to learn about how these notifications impact new users. We will revisit.

JTannerWMF moved this task from To Triage to FY 2019-20 on the Growth-Team board.Aug 23 2018, 12:17 PM

I don't understand how this is related. The request is to enable experienced users to turn this off, not to remove it from new users.

Alsee added a comment.Aug 23 2018, 6:54 PM

We are going to wait a little bit as we continue to learn about how these notifications impact new users.

Ah, good. Is there a page I can watchlist for work/results on this new research project?

The request is to enable experienced users to turn this off, not to remove it from new users.

As one of several people who have complained about milestones, I renew my request to eliminate them completely. Previous WMF research on similar milestone messages is very suggestive that these messages may be driving away editors. Due to the extremely high standard deviation of the data no individual result reached statistical significance. However there was a consistent pattern across the set of results: After each and every milestone message there was a decline in the number of people who contributed further. It appears that the results may be statically significant when examined as a group. I suspect any effect will be more pronounced when milestones are delivered by Notification than when they were presented as ephemeral popups.

There is a view among some people, perhaps more common among people inclined to edit an encyclopedia, that these computer generated messages are annoying, condescending, and reflect very negatively on any website sending them.

An alternative proposal (and also something that I think is worth doing regardless, if we keep these notifications), is for these notifications to be based on the global edit count rather than the local edit count. That would remove a major source of annoyance for experienced users who get 1st and 10th edit notifications from wikis that they edit infrequently.

Yes please! I've likely received over 100 of these notifications, and every time I do I feel like I've wasted 2 seconds of my life. Granted, that only amount to 200 wasted seconds, but still!

JTannerWMF moved this task from FY 2019-20 to Q3 2018-19 on the Growth-Team board.Jan 3 2019, 3:57 PM

Any update on this?

JTannerWMF edited projects, added Growth-Team (Current Sprint); removed Growth-Team.

Change 502893 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/Echo@master] Make thank-you-edit notifications configurable

https://gerrit.wikimedia.org/r/502893

@MMiller_WMF What would you like the new preference to say (main text and tooltip)? It's the last one on the list in the screenshot below. I put it last but let me know if you would prefer it somewhere else.