Page MenuHomePhabricator

Deploy Replying v2.0 as Beta Feature to partner wikis
Closed, ResolvedPublic

Description

"2.0" = DiscussionToolsEnableVisual


This task is about making the Reply tool's visual mode available within the existing DiscussionTools Beta Feature that is deployed at our four partner Wikipedias: Arabic, Dutch, French and Hungarian. More details below.

Deployment timing

  • @ppelberg to finalize and notify engineering.
    • This should be deployed today, 17-June.

Deployment details

  • In making this change, the Reply tool's visual mode will become available wherever the tool is currently available (parter wikis, beta cluster, url parameter)
    • Where "become available" means people will see the visual tab within the Reply tool's toolbar. [i]
  • In making this change, we need to preserve the ability to "turn off" the tool's visual mode if issues arise that warrant doing so

Done

  • The "Deployment details" above have been implemented

i.

Related Objects

StatusSubtypeAssignedTask
OpenNone
Resolvedppelberg
ResolvedEsanders
ResolvedDLynch
Resolvediamjessklein
ResolvedEsanders
Resolvediamjessklein
ResolvedEsanders
Resolvedppelberg
ResolvedBUG REPORTppelberg
ResolvedBUG REPORTEsanders
Resolvedppelberg
ResolvedEsanders
ResolvedWhatamidoing-WMF
DuplicateNone
Resolvedppelberg
ResolvedMayakp.wiki
ResolvedDLynch
ResolvedMayakp.wiki
ResolvedRyasmeen
ResolvedRyasmeen
ResolvedDLynch
ResolvedMayakp.wiki
Resolvedppelberg

Event Timeline

Change 605642 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/DiscussionTools@master] Set DiscussionToolsEnableVisual to true by default

https://gerrit.wikimedia.org/r/605642

Update
Notes from this morning's standup; the below is now represented in the task description as well...

  • In making this change, the Reply tool's visual mode will become available, by default, wherever the tool is currently available (parter wikis, beta cluster, url parameter)
  • In making this change, we need to preserve the ability to "turn off" the tool's visual mode if issues arise that warrant doing so

Next steps

Change 605997 had a related patch set uploaded (by Esanders; owner: Esanders):
[operations/mediawiki-config@master] Set DiscussionToolsEnableVisual to true by default

https://gerrit.wikimedia.org/r/605997

Next steps

This should be deployed today, 17-June.

Change 605997 merged by jenkins-bot:
[operations/mediawiki-config@master] Set DiscussionToolsEnableVisual to true by default

https://gerrit.wikimedia.org/r/605997

Mentioned in SAL (#wikimedia-operations) [2020-06-17T18:14:22Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: c9f6452: Set DiscussionToolsEnableVisual to true by default (T251654) (duration: 00m 56s)

matmarex removed a project: Patch-For-Review.
matmarex added a subscriber: matmarex.

Deployed, everything looks good to me.

Deployed, everything looks good to me.

Excellent.

I checked this today on all four target wikis. Verified the basic functionalities, all the options under VE mode, text formatting, link, username auto suggestions, username mention icon functionality and did a quick re-check on editor preference. Everything looks okay to me. I have found the following issue however: T256089.
Over to you @ppelberg.

ppelberg claimed this task.

I checked this today on all four target wikis. Verified the basic functionalities, all the options under VE mode, text formatting, link, username auto suggestions, username mention icon functionality and did a quick re-check on editor preference. Everything looks okay to me. I have found the following issue however: T256089.

Excellent. Closing this out. Thank you, Rummana.

Change 605642 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Set DiscussionToolsEnableVisual to true by default

https://gerrit.wikimedia.org/r/c/mediawiki/extensions/DiscussionTools/ /605642

(This patch doesn't affect the production wikis, it only changes the defaults for hypothetical third-party users and Patchdemo)