Page MenuHomePhabricator

Next Phabricator Upgrade - 2016-02-18
Closed, ResolvedPublic

Description

MediaWiki / Phabricator / Maintenance

Event: {E142} - This is Tentatively scheduled for Thursday, February 18th @ 01:00 UTC

Tasks solved upstream but still not deployed on phabricator.wikimedia.org should add this task as blocker. When there are significant / important blockers, @mmodell will pull from upstream and deploy during the soonest available deployment window.

Other Deployments:

Details

Related Gerrit Patches:
operations/puppet : productionupdate phabricator to release/2016-02-18/1

Related Objects

StatusAssignedTask
ResolvedNone
ResolvedNone
ResolvedNone
Resolvedepriestley
ResolvedNone
Resolvedmmodell
OpenNone
Resolvedmmodell
ResolvedAklapper
Resolvedmmodell
ResolvedAklapper
DeclinedNone
Resolvedmmodell
ResolvedNone
Declinedmmodell
Resolvedmmodell
Resolvedmmodell
ResolvedAklapper
Resolvedmmodell
ResolvedNone
DeclinedVarnent
Resolvedmmodell
Resolvedmmodell
ResolvedTTO
Resolvedmmodell
Resolvedmmodell
ResolvedAklapper
ResolvedAklapper
ResolvedAklapper
DeclinedNone
ResolvedNone
ResolvedAklapper
ResolvedAklapper
Resolvedmmodell
Resolvedmmodell
ResolvedDStrine
Resolvedcsteipp
Resolved ksmith

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Elitre added a subscriber: Elitre.Dec 9 2015, 2:57 PM

I've deployed all the latest upstream changes to https://phab-01.wmflabs.org for testing. I've also created some custom forms to experiment with the new features.

Luke081515 moved this task from To Triage to Misc on the Phabricator board.Jan 21 2016, 9:50 PM
Meno25 added a subscriber: Meno25.Feb 7 2016, 12:47 PM
mmodell renamed this task from Next Phabricator Upgrade to Next Phabricator Upgrade - 02-18-2016.Feb 10 2016, 1:24 AM
mmodell updated the task description. (Show Details)
mmodell updated the task description. (Show Details)

I poked around a little bit to see if I could catch other any likely issues.

Possible stuff that might need attention:

  • The patch in T84833 likely needs a small update (but that might already have been taken care of).
  • T624 might be close enough to fixed to close, or might need a partial revert -- new upstream behavior isn't the same as the requested beahvior.

Stuff that's probably fixed:

  • I think T99035 is mooted for now, although we may cause the problem again in the future.
  • I think T86458 is mostly fixed, maybe close enough.
  • T122253 will become fixable in the UI (probably an effective dupe of T105865).
  • The "give Phacility money" part of T106130 is moot, although I don't expect to clear the underlying issue before the update happens.
  • I think T122875 is fixed.
  • I think T121071 is fixed (and T118014 is probably a dupe of it).

After some upstream activity, T84833 is probably effectively resolved now, and the patch can likely be reverted and replaced with configuration if it made it into production. The new behavior may be slightly more flexible than the requested behavior.

@Christopher: Can you comment to let me know which upstream revision you are currently supporting with the Sprint extension, and ideally tag a revision of Sprint that I can pin for this release?

@mmodell My current plan is to remove all workboard classes from the sprint extension since https://secure.phabricator.com/T10328 has finally implemented the same functionality, including totalling column points. This will save a lot of continued maintenance.

Is the plan to enable the new points field? If so, then a general guide for how people can use this new field should also be implemented. I would really like to use this new field instead of the custom field for the charts, but switching it will totally break all existing story point usage. Maybe you can figure out a way to migrate the existing sprint points to the new field?

I am not sure if it is possible to complete all of this by Wednesday. I would actually recommend possibly postponing the upgrade so that a more comprehensive plan can be developed for milestones and the points field usage, because this provides a key new feature for Agile teams.

Or, alternatively, you can do the upgrade up to c01f23adfb82295588e3a9536f5281f32eef2b6e 04.02.2016 with the latest commit from the sprint extension. It should be stable. Also, it is possible to disable the sprint boards from the sprint config, which would essentially guarantee that everything works properly.

There's a script for doing most of the work to copy points available here:

https://secure.phabricator.com/T10350

Luke081515 renamed this task from Next Phabricator Upgrade - 02-18-2016 to Next Phabricator Upgrade - 2016-02-18.Feb 13 2016, 5:31 PM
Restricted Application added a project: TCB-Team. · View Herald TranscriptFeb 15 2016, 2:42 PM

Change 271439 had a related patch set uploaded (by 20after4):
update phabricator to release/2016-02-18/1

https://gerrit.wikimedia.org/r/271439

Change 271439 merged by Rush:
update phabricator to release/2016-02-18/1

https://gerrit.wikimedia.org/r/271439

mmodell closed this task as Resolved.Feb 18 2016, 3:46 AM
Qgil awarded a token.Feb 18 2016, 9:43 AM
Meno25 removed a subscriber: Meno25.Feb 19 2016, 3:40 PM
Tobi_WMDE_SW moved this task from Incoming to Done on the TCB-Team board.Mar 17 2016, 2:01 PM
Danny_B moved this task from Misc to Upgrades on the Phabricator board.Jul 12 2016, 12:18 PM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptJul 12 2016, 12:18 PM