Page MenuHomePhabricator

Send a notification when someone else edits your userpage
Open, LowestPublic

Description

Before merging, this should have a $wgEchoUserPageEditNotification variable to enable it, defaulted false (like $wgEchoMentionStatusNotifications). This lets us control when it goes to production.

Also, fill out the form at https://phabricator.wikimedia.org/T168385#3439975 , and let product review, before merge.


I _have_ implemented this feature; it comes as a (positive) side-effect within
the ENotif version see http://bugzilla.wikipedia.org/show_bug.cgi?id=454 (pls.
add you e-mail address to the CC of
http://bugzilla.wikipedia.org/show_bug.cgi?id=454 , if you want to receive news
about this.

The flag is shown, as long as not-yet-seen changes on both the user_talk or user
page are pending. This is currently implemented as configurable feature
depending on value of $wgShowNewtalkForUserOrUserTalkPage (true, false).

Tom (Wikinaut)

See also T4014: Patchlet 1: ENotif code clean-up patch for REL1_5 - revisited.


Version: 1.5.x
Severity: enhancement
URL: http://www.enotifwiki.org

See also:

Details

Commits
Unknown Object (Diffusion Commit)
Reference
bz1876

Related Objects

StatusAssignedTask
InvalidAklapper
InvalidNone
ResolvedNone
InvalidWikinaut
OpenNone
OpenJoHammer
InvalidNone
ResolvedWikinaut
ResolvedNone
DeclinedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedWikinaut
DeclinedNone
DeclinedNone
ResolvedNone
DeclinedNone
DeclinedAklapper
ResolvedNone
ResolvedNone
ResolvedNone
Resolvedhashar
Resolvedhashar
Resolvedhashar
ResolvedNone
ResolvedNone
Resolvedhashar
Resolvedhashar
Resolvedhashar
Resolvedhashar
ResolvedNone
ResolvedNone
Resolvedhashar
ResolvedNone
DeclinedWikinaut
ResolvedWikinaut
ResolvedWikinaut

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 8:21 PM
bzimport added a project: MediaWiki-Parser.
bzimport set Reference to bz1876.
bzimport added a subscriber: Unknown Object (MLST).
Wikinaut created this task.Apr 12 2005, 5:27 PM

*implemented* in ENotif/EConfirm v3.16, see
http://bugzilla.wikipedia.org/show_bug.cgi?id=454 .
I cannot say, whether this will be implemented in public release version or not,
but I fully support it.

I need to know, whether you want to have this, whether you want me to publish a
clean patch for CVS REL1_5 for this feature.

You can try it out on http://www.enotifwiki.org , which runs this feature live.

A REL_15 patch for this enhancement bugzilla is available in form of a
cumulative patch (fixing also mainly cosmetic issues of Enotif as in REL1_5).

You might wish to test this proposed feature of a new message marker for
user-talk _and_ user pages live on the wiki http://www.enotifwiki.org . A recent
discussion on IRC received wholehearted welcomes.

(In reply to comment #4; correction; addendum)

A REL1_5(corr'd) patch for this enhancement bugzilla is available in form of a
cumulative patch [1,2] (fixing also mainly cosmetic issues of Enotif as in

REL1_5).

[1] http://bugzilla.wikipedia.org/attachment.cgi?id=785&action=view
[2] http://bugzilla.wikimedia.org/show_bug.cgi?id=2014

gangleri wrote:

Hi Tom!

I think it is a very good idea to expand the "E-mail me when my user talk page
is changed" function.

I modified user pages by mistake in the past because I was confused at some
accounts (in varios alphabets) where neither the user page nor the user talk
page did exist before.

Beside mistake it would be good to know if "your user page" gets midified
(corected or vandalised). I think this is the main reason addressed in a
restrictive request as
Bug 2352: New feature to automatically protect user: page

A point to think about relates to the "subpages" of both the user page and the
talk page. Sould these be covered as well?

To reduce the number of options I suggest to use only "the whole bundle" i.e.
the user page, the user talk page (eventualy also the subpage) and
[[MediaWiki:Tog-enotifusertalkpages]].

I want to mention here also
Bug 4101: send ENotif if user page and / or user talk page is deleted

Brion is fixing bug 3805 and bug 4201.

best regards reinhardt [[user:gangleri]]

cannon.danielc wrote:

*** Bug 2044 has been marked as a duplicate of this bug. ***

cannon.danielc wrote:

*** Bug 12040 has been marked as a duplicate of this bug. ***

*** Bug 13985 has been marked as a duplicate of this bug. ***

T. Gries:
This report has been in ASSIGNED status for more than one year and you are set as its assignee. In case that you are not actively working on a fix, please reset the bug status to NEW/UNCONFIRMED.
In case you do not plan to work on a fix in the near future: Please also edit the "Assigned To" field by clicking "Reset Assignee to default", in order to not prevent potential contributors from working on a fix. Thanks for your help!
[assigned>=1y]

Qgil set Security to None.
Qgil added a subscriber: Qgil.

Hasn't this old task been fixed with the orange bar, a long time ago?

Mattflaschen-WMF lowered the priority of this task from Normal to Lowest.Dec 19 2014, 7:05 PM
In T3876#935691, @Qgil wrote:

Hasn't this old task been fixed with the orange bar, a long time ago?

IIRC, the orange bar (both the Echo version and the regular one) only notifies you of edits to your user talk page.

This is asking to do the same for the user page (and perhaps your whole userspace). It wasn't originally an Echo bug and I think it still applies to both Echo and vanilla user talk notifications.

This is an enhancement request, so we would also have to discuss if we want to do this.

epriestley closed this task as Resolved by committing Unknown Object (Diffusion Commit).Mar 4 2015, 8:23 AM
epriestley added a commit: Unknown Object (Diffusion Commit).
Qgil reopened this task as Open.Mar 4 2015, 8:36 AM

Accidental clash. Known issue. Reverting status.

Quiddity renamed this task from Show "You have new messages on your user or user_talk page" -- i.e. both pages are notified to Send a notification when someone else edits your userpage.Sep 7 2015, 10:16 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptSep 7 2015, 10:16 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

I think that should also work for subpages.

There is a request from German Wikipedia about having a Notification when someone else modify your user page. May be an alert.

Fresh request for this feature from a Slovenian-language editor, at https://www.mediawiki.org/wiki/Topic:Tlgxli72jrmajwpw and specifically mentioning subpages.

I miss notifications if someone edited my user page or subpage.

Qgil removed a subscriber: Qgil.Feb 22 2017, 10:34 AM

Fresh request for this feature at Enwiki.

Can we add a notification for user page edits?

NeilN added a subscriber: NeilN.Mar 22 2017, 7:31 PM

Should it be proposed as a possible task for the next hackathon?

Gestrid added a subscriber: Gestrid.Jun 8 2017, 7:46 AM

I pinged @jmatazzoni and the team to ask if we want to implement this.

JoHammer claimed this task.Aug 13 2017, 6:52 PM

Change 371738 had a related patch set uploaded (by JoHammer; owner: JoHammer):
[mediawiki/extensions/Echo@master] send a notification if someone else edits your userpage

https://gerrit.wikimedia.org/r/371738

Restricted Application added a project: Growth-Team. · View Herald TranscriptSep 4 2018, 1:59 PM