Page MenuHomePhabricator

Deploy Replying as opt-out Preference at the Arabic, Czech and Hungarian Wikipedias
Closed, ResolvedPublic

Description

This task is about deploying the Reply Tool as an opt-out Preference on our four partner Wikipedias: Arabic, Dutch, French and Hungarian at the Arabic, Czech and Hungarian Wikipedias.

The goal of this step in our deployment process [1] is to answer the following questions:

  1. Are people able to successfully post replies using the feature?
  2. Is the feature having any unintended affects (e.g. encouraging disruptive talk page comments edits)?
  3. Are people finding the feature valuable?

To help answer these questions, we will evaluate a set of engagement metrics. The work to calculate these metrics will happen in this task: T247139.

Note: work on this task will not begin until we have a better understanding for how Replying v1.0 is being used as a Beta Feature. See: T249386.

Deployment timing

The Reply Tool will be made available as an opt-out feature on Thursday, 24-September.

Wikis to test

This section lists the wikis where the Reply Tool should be tested.

WikipediaLanguage code
Arabicar
Czechcs
Hungarianhu

Testing instructions

Scenario A
As a logged out user, at each of the ===Wikis to test listed above:

  1. Visit a talk page and confirm [ reply ] links appear.
  2. Open the Reply Tool and document the text input mode – source or visual – that is shown by default.
  3. Post a comment using the Reply Tool, open the Reply Tool again and document the text input mode – source or visual – that is shown

Scenario B
Create a new account and at each of the ===Wikis to test listed above:

  1. Visit a talk page and confirm [ reply ] links appear.
  2. Open the Reply Tool and document the text input mode – source or visual – that is shown by default.
  3. Post a comment using the Reply Tool, open the Reply Tool again and document the text input mode – source or visual – that is shown

Text input mode behavior

WikiDefault input mode shown (logged out)Default input mode shown (new account)Input mode shown after publishing a comment (logged out)Input mode shown after publishing a comment (new account)
ar.wikiVisualVisualNot testedRemembers the last used editor
cs.wikiVisualVisualNot testedRemembers the last used editor
hu.wikiVisualVisualNot testedRemembers the last used editor

Open questions

  • For whom should version 2.0 of the Replying tool be made available as an opt-out feature?
    • All volunteers (logged in/out) at the Arabic, Czech and Hungarian Wikipedias except for those people who have explicitly turned off the DiscussionTools Beta Feature. ⚠️Note: this is NOT technically possible; see: T259943#6449398.
  • When should the Reply Tool be made available as an opt-out feature?
    • The Reply Tool will be made available as an opt-out feature on Thursday, 24-September.

Done

  • "Open questions} have been resolved
  • The Reply Tool is available as an opt-out feature for all volunteers at the following Wikipedias: Arabic, Czech and Hungarian

Related Objects

StatusSubtypeAssignedTask
OpenNone
OpenNone
OpenNone
Resolvedppelberg
ResolvedMNeisler
ResolvedWhatamidoing-WMF
Resolvedppelberg
OpenRyasmeen
Resolvedmatmarex
Resolvedppelberg
OpenDLynch
Resolvedmatmarex
Resolvedppelberg
ResolvedEsanders
Resolvedmatmarex
ResolvedEsanders
Resolvediamjessklein
Resolvedppelberg
OpenEsanders

Event Timeline

ppelberg created this task.Apr 4 2020, 1:21 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 4 2020, 1:21 AM
ppelberg renamed this task from Deploy Replying v1.0 as opt-out Preference on partner wikis to Deploy Replying as opt-out Preference on partner wikis.May 2 2020, 12:54 AM

Is this really about deploying version 1.0? Aren't you going to deploy version 2.0?

Is this really about deploying version 1.0? Aren't you going to deploy version 2.0?

Good spot – thank you for saying something, @AdHuikeshoven. This task is about deploying version 2.0.

...I've updated the task description to reflect this.

ppelberg updated the task description. (Show Details)Jul 10 2020, 4:00 PM
ppelberg updated the task description. (Show Details)
ppelberg updated the task description. (Show Details)

Deploying timing update
We had *initially* planned for the Reply Tool to be deployed as an opt-our preference on at least one partner wiki next week (the week of 17-August).

This date has since been pushed back and a new date has not yet been set. Once it has been, I will update this ticket.

ppelberg updated the task description. (Show Details)Sep 9 2020, 6:20 PM
ppelberg updated the task description. (Show Details)

Task description update

  • ADDED potential deployment timing: the week of 14 or 21-Sep
  • MODIFIED Wikipedias where the Reply Tool will be made available.
    • Now: Arabic, Czech and Hungarian Wikipedias
    • Had been: Arabic, Dutch, French and Hungarian Wikipedias
ppelberg updated the task description. (Show Details)Sep 9 2020, 7:01 PM

Update: Probably Tuesday, 22 September 2020. But that's "probably", not "definitely".

Patriccck updated the task description. (Show Details)Sep 11 2020, 8:12 PM
Patriccck renamed this task from Deploy Replying as opt-out Preference on partner wikis to Deploy Replying as opt-out Preference at the Arabic, Czech and Hungarian Wikipedias.Sep 11 2020, 8:25 PM
Restricted Application added a subscriber: alanajjar. · View Herald TranscriptSep 11 2020, 8:25 PM
ppelberg updated the task description. (Show Details)Sep 22 2020, 1:07 AM
ppelberg updated the task description. (Show Details)Sep 23 2020, 6:09 PM
ppelberg updated the task description. (Show Details)

Deployment timing update

Per the conversation we had during today's team meeting, the Reply Tool should be made available to all users at the Arabic, Czech and Hungarian Wikipedias, tomorrow, 24-September-2020.

The task description has been updated to include this.

cc @matmarex who will comment which deployment window [1] this will happen in.


  1. https://wikitech.wikimedia.org/wiki/Deployments#Thursday,_September_24

Note: you'll notice several of this sub-tasks remain open. This is expected. The tasks that remain open, fall into the following categories:
1. Tasks whose core work is done and have some remaining, non-blocking actions (e.g. T262988 , T249391 and T262332 )
2. New issues that surfaced during QA that are non-blocking (T262501, T263061, T263062 and T263607)

ppelberg updated the task description. (Show Details)Sep 23 2020, 6:34 PM

Change 629470 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[operations/mediawiki-config@master] Move DiscussionTools out of beta on arwiki, cswiki, huwiki

https://gerrit.wikimedia.org/r/629470

Change 629470 merged by jenkins-bot:
[operations/mediawiki-config@master] Move DiscussionTools out of beta on arwiki, cswiki, huwiki

https://gerrit.wikimedia.org/r/629470

Mentioned in SAL (#wikimedia-operations) [2020-09-24T11:14:43Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: 90c72912f26d91df6d28b1efd64e366aaabc5357: Move DiscussionTools out of beta on arwiki, cswiki, huwiki (T249394); d8553f35b4dd581f67bd568d773ff65f316fbfd3: Simplify DiscussionTools config (duration: 01m 11s)

  • Logged in users should see the reply links since that change was deployed (a few hours ago)
  • Logged out users might not see them yet due to caching, these caches should expire within 24 hours (according to this page: https://wikitech.wikimedia.org/wiki/Varnish#TTL and confirmed by cdanis on IRC)
Patriccck updated the task description. (Show Details)Sep 24 2020, 6:50 PM
Ryasmeen updated the task description. (Show Details)
ppelberg closed this task as Resolved.Wed, Sep 30, 2:58 AM
ppelberg claimed this task.