Goal: The majority of WMF developer teams and sprints have moved to Phabricator
Closed, ResolvedPublic

Description

From all the Wikimedia Foundation teams developing software, more than half of the teams and more than half of the ongoing sprints should have moved to Phabricator by the end of 2014.

Quim Gil, 01/11/2014 15:30:

we can support more teams moving in. The value of this bit of extra
rush is better testing, better prioritization of tasks, building
momentum, and growing the community of early birds who will help
supporting the big wave of new users that will come at once.

Checklist of WMF tech teams that either have an own subtask or don't have any projects to migrate from Trello / Mingle / other (feel free editing the list directly):

  • Product management
  • Community Engagement
  • Team Practices
  • Design
  • Technical Operations
  • Analytics
  • MediaWiki Core
  • Engineering Community
  • Release Engineering
  • Multimedia
  • Core Features
  • Editing
  • Parsoid
  • Fundraising Tech
  • Language
  • Mobile Apps
  • Mobile Web
  • Wikipedia Zero

Related Objects

StatusAssignedTask
ResolvedQgil
ResolvedQgil
ResolvedQgil
Resolvedgreg
DuplicateNone
Resolvedggellerman
ResolvedNone
InvalidNone
DuplicateNone
ResolvedAklapper
DeclinedNone
ResolvedGilles
ResolvedNone
DeclinedQgil
Resolvedchasemp
Resolvedchasemp
ResolvedChristopher
ResolvedChristopher
Resolved Spage
ResolvedArrbee
ResolvedAklapper
ResolvedArrbee
ResolvedJdlrobson
Resolvedatgo
ResolvedNone
OpenNone
Resolved mmodell
DeclinedQgil
ResolvedQgil
Resolvedaripstra
ResolvedDbrant
OpenNone
Resolved mmodell
ResolvedBBlack
Resolvedcsteipp
ResolvedBBlack
DeclinedBBlack
ResolvedPaladox
Resolved Spage
Resolved Spage
ResolvedQgil
Qgil created this task.Oct 23 2014, 6:33 AM
Qgil updated the task description. (Show Details)
Qgil raised the priority of this task from to Normal.
Qgil claimed this task.
Qgil changed Security from none to None.
Qgil updated the task description. (Show Details)Oct 23 2014, 8:28 AM
Qgil removed a subscriber: Jaredzimmerman-WMF.

Just a note that it is likely worthwhile to separate 'mobile' to 'mobile web' and 'mobile apps' as they are discrete teams and use separate trello boards/workflows.

Qgil updated the task description. (Show Details)Oct 25 2014, 6:59 AM
Nemo_bis updated the task description. (Show Details)Nov 2 2014, 9:58 AM
Qgil moved this task from Backlog to Doing on the ECT-October-2014 board.Nov 4 2014, 8:11 AM
Eloquence added a comment.EditedNov 24 2014, 6:29 PM

WP Zero has a confidential Trello board to track partner deployments, which we should migrate if we can manage the security, as well as the actual development backlogs (some individual tasks of which may need to be private). @dr0ptp4kt @Yurik

Qgil added a project: Epic.Jan 8 2015, 12:45 PM
mark removed a subscriber: mark.Jan 8 2015, 1:09 PM
Qgil moved this task from To Triage to Doing on the Phabricator board.Jan 12 2015, 10:28 AM
Qgil closed this task as Resolved.Jan 16 2015, 10:07 AM
Qgil added a subscriber: Aklapper.

From all the Wikimedia Foundation teams developing software, more than half of the teams and more than half of the ongoing sprints should have moved to Phabricator by the end of 2014.

Yesterday we had Engineering Community team quarterly review. We presented our data (T434) and agreed that the basic goal has been achieved. We noted that the migration of teams using Trello still requires special attention, and @Aklapper has a related goal for the current quarter: WMF teams still using Trello have identified actionable blockers.

In the review we mentioned that an obvious part of the problem is that T821: Trello -> Phabricator migration script is not ready. We also discussed about the missing features that Trello users are considering blockers, and that it is very unlikely that upstream or ourselves will work on any time soon. We also mentioned that a lesson we learned in the past months is that there are other obstacles beyond software, and that there is some correlation between the autonomy/dependency of a team versus the rest of teams and the interest in leaving Trello to embrace Phabricator.

The general WMF engineering inertia toward Phabricator is clear, and it will surely influence the plans of the Trello users, but I think each case is quite different, and we will need to look case by case.

Back to the first point, I'm closing this task as Resolved. Big thank you to anybody involved!

Congratulations! This is a big accomplishment.

Restricted Application added a subscriber: scfc. · View Herald TranscriptJun 30 2015, 8:43 PM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptAug 13 2016, 8:39 PM