Page MenuHomePhabricator

Make redirect into a toast message
Closed, ResolvedPublic2 Story Points

Description

story
As a user, i don't want to be reminded about the redirect to this page while I'm reading the article. it's distracting.
description
Redirect notice should be a temporary message when user lands on an article. Mobilefrontend has a toast system that can inform the user that the user landed on this page as a result of a redirect. which can be auto dismissed.

Mock:
Before


Notice the (redirect from Obama) message

After

  • Add new toast message
  • remove the redirect notice under the title which is not even formatted.

Note: for non-JS users, hide redirect message.
Note: this task refers only to the redirect message. disambiguation text, other redirect information, and article notes will still be available.

A/C

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterMove redirect message to toast

Related Objects

StatusAssignedTask
OpenNone
ResolvedJdlrobson
Resolvedovasileva
Resolvedphuedx
DuplicateNone
Resolvedovasileva
ResolvedJdlrobson
InvalidNone
ResolvedCKoerner_WMF
ResolvedCKoerner_WMF
InvalidNone
Resolvedovasileva
Resolvedalexhollender
Duplicatealexhollender
Resolvedalexhollender
Resolvedovasileva
Resolvedalexhollender
ResolvedRyasmeen
ResolvedRyasmeen
ResolvedNiedzielski
Resolvedovasileva
ResolvedNone
Resolvedovasileva
ResolvedABorbaWMF
Resolvedalexhollender
DuplicateNone
ResolvedNiedzielski
Resolvedovasileva
Resolvedovasileva
Resolvedphuedx
Resolved Tbayer
Resolvedovasileva
ResolvedNiedzielski
Resolved Tbayer
Resolved Tbayer
Resolved Tbayer
Resolved Tbayer
Resolvedovasileva
Resolved Tbayer
Resolvedphuedx
Resolvedovasileva
ResolvedJdlrobson
ResolvedJdlrobson
Resolved Tbayer
Resolved Tbayer
ResolvedNiedzielski
DeclinedNone
Resolvedovasileva
OpenNone
ResolvedJdlrobson

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
jhobs moved this task from Incoming to Needs Prioritization on the Readers-Web-Backlog board.

While the proposed solution is cleaner, it gets rid of some important links like disambiguation page link.

it gets rid of some important links like disambiguation page link.

disambiguation link? i thought redirect message right now only has link to the redirect page.

I see, so you're talking about

(Redirected from Obama)

And not about (which confusingly has the redirect text):

"Barack" and "Obama" redirect here. For his father, see Barack Obama Sr. For other uses of "Barack", see Barack (disambiguation). For other uses of "Obama", see Obama (disambiguation).

Nirzar added a comment.EditedOct 7 2016, 5:56 PM

Yes, this is just about the (redirect from Obama) which shouldn't be a permanent message in 16px on top of everything. (btw which is not even aligned properly) :(

@bmansurov oh yeah it's confusing. let me add before after so people can understand. sorry about that

Nirzar updated the task description. (Show Details)Oct 7 2016, 6:34 PM

I think Special:Preferences does something similar for delivering notifications on page load. We can probably reuse that code.

ovasileva updated the task description. (Show Details)Oct 17 2016, 4:35 PM
ovasileva set the point value for this task to 2.
Nirzar removed Nirzar as the assignee of this task.Oct 19 2016, 7:09 PM
Volker_E added a subscriber: Volker_E.

Shouldn't the task description say “for non-JS users show redirect message”?

Shouldn't the task description say “for non-JS users show redirect message”?

I agree, I personally want to see the redirect message for non-JS users.

jhobs moved this task from To Do to Doing on the Reading-Web-Sprint-84-Zero-minutes-left board.

@jhobs do you need any help with this task? Any blockers?

Change 319323 had a related patch set uploaded (by Jhobs):
Move redirect message to toast

https://gerrit.wikimedia.org/r/319323

@bmansurov I had been a bit stuck with a circular dependency problem (that took a long time to diagnose) because I originally tried to add this functionality to mobile.startup. Once that was finally diagnosed, I then went hunting for an alternative place for this code to live and landed on skins.minerva.scripts/preInit.js. I'm not sure it's the best place for it, but that can be discussed in code review on gerrit.

FYI, the current patch leaves the message visible for non-js users, as discussed in the comments. I'm a bit hesitant to change the description just yet because I'd like to make sure @Nirzar has seen and accepts this slight change in acceptance criteria first.

Florian added a subscriber: Florian.Nov 2 2016, 4:23 PM

While I think it's a good point to invest some design work into this ugly and unaligned message, I don't think, that removing functionality is a good solution. With this change, mobile users aren't "allowed" to access redirect pages anymore (the source page), to, e.g., change or remove the redirect (the "redirect=no" url parameter). There should be an option for mobile users to do this, without leaving the mobile website. Maybe @Nirzar could add such a possibility to the Mock? :)

That's a good point @Florian
@Nirzar how do we intend to allow editors to be able to navigate to the redirect page itself? By clicking the toast?

Nirzar added a subscriber: ovasileva.EditedNov 2 2016, 8:24 PM

@Florian I understand the concern. we were debating the use of functionality that you have mentioned and your thoughts around that would be really helpful.

for a regular reader, how valuable is a redirect page itself. i agree the redirect information is valuable and we would be retaining that through a toast. the information on redirect page is a single piece of information (A redirects to B) and I would like to know other motivations behind visiting redirect pages so we can better serve it apart from this change proposed here in the card.

Other idea
maybe we can make the toast click-able to retain the functionality? clicking on toast would take you the redirect page?

The issue is, every single thing is a use-case for some set of users and we have to balance the importance of information based on the demographics we are trying to serve.

It's difficult to make choices for people we are trying to reach. one main goal we have is to make it easy for anyone to read the article within first glance. we will be talking about the top of the page article layout really soon with everyone. which will have these points of discussions cc @ovasileva

Consider a situation where some vandal makes https://en.m.wikipedia.org/wiki/Big Idiot redirect to a living person and an editor needs to be able to fix that promptly. The editing use case may be better served by adding this link to the editor when you click edit. Essentially editors need to be able to easily go to and edit the redirect page - this change would mean they need to remember and type the url to https://en.m.wikipedia.org/w/index.php?title=Obama&redirect=no

phuedx added a subscriber: phuedx.Nov 3 2016, 1:51 PM

I've +1'd rEMFR01768b089c61: Move redirect message to toast.

@Nirzar, @Florian, @Jdlrobson: I'm not sure that there's an agreed path forward. Do we make the toast clickable? Where should we put the rationale and mocks to which we can point other community members with similar concerns?

phuedx changed the task status from Open to Stalled.Nov 3 2016, 9:36 PM
phuedx removed jhobs as the assignee of this task.
phuedx added a subscriber: jhobs.
phuedx assigned this task to jhobs.Nov 3 2016, 9:39 PM

^ Because @jhobs's change has been code reviewed and tested (twice).

Let's make the toast clickable to preserve current functionality. However, I'd like to point out that the portion of editors who might edit the redirect page on mobile would be relatively small which would still make this an edge case.

jhobs changed the task status from Stalled to Open.Nov 7 2016, 6:05 PM

Per a discussion during kickoff, we will be continuing this task as-is and addressing the identified editor use case in T150189: Make toasts tappable links when redirecting a user away from a page. This means https://gerrit.wikimedia.org/r/#/c/319323/ is ready for merge per the review on the task.
cc @bmansurov @phuedx

Change 319323 merged by jenkins-bot:
Move redirect message to toast

https://gerrit.wikimedia.org/r/319323

Was moved on the wrong board.

I'm still seeing the gray redirect notice on the beta cluster. Looks like this needs more work.


This one is created by a template, so it's content. The notice directly under the title of


(see the "Redirected from Obama" text)

is hidden now.

Got it! Thanks @Florian I misunderstood the task and thought the goal was to remove all redirect text. I guess not!

@Jdlrobson Yeah that confused me at first too. Disambig-related redirect text is left intentionally. :)

leaving a note in the description, just to clarify

ovasileva updated the task description. (Show Details)Nov 8 2016, 12:56 PM

@Jdlrobson i will create another task for better toast messages on bigger screens. :( just a reminder. we can add it to backlog of "better systems for large screens"

On

and on Android, and on iOS I'm still seeing toast messages (that needs work), there is no toast message on Opera Mini on Android as expected.

ovasileva closed this task as Resolved.Nov 9 2016, 10:12 AM

@Nicholas.tsg - toast messages should appear on the above mentioned browsers (on all but opera mini and other non-js browsers). Works as expected. Signing off.

Jdlrobson reopened this task as Open.Nov 14 2016, 9:06 AM

I found a bug (see subtask)... :/

jhobs closed this task as Resolved.Nov 14 2016, 5:00 PM
jhobs removed Nicholas.tsg as the assignee of this task.

@Jdlrobson this task has already been merged, signed off, and deployed. I think keeping this resolved and opening the bug as its own task is fine, especially since there were no mentions of multi-word titles in the design spec (I obviously still should have caught it though). We wouldn't re-open our original language switcher task if we found a new bug with it, for example. ;)

Jdlrobson reopened this task as Open.Nov 14 2016, 8:29 PM

Per standup. Sign off when subtask is fixed!

ovasileva closed this task as Resolved.Nov 16 2016, 12:48 PM
ovasileva claimed this task.

all done! just a question - @jhobs - what is the timing on the toast?

I believe it stays for about 2s, although I'm not certain. It's whatever the default timing is, so it should be the same as all our other toasts.

@jhobs is timing a parameter for toast system?

Sorry for butting in @jhobs

@Nirzar: The toast is automatically hidden after 5 seconds. This timeout isn't configurable per-toast.