Page MenuHomePhabricator

Bump onoi/message-reporter in vendor.git to 1.4.2 for php 8 support
Closed, ResolvedPublic

Description

vendor.git currently requires version 1.4.1 of onoi/message-reporter. This is breaking tests on php8, as you need 1.4.2 for php 8 support

Wikibase says it needs ~1.4, so updating this should be fine.

Related Objects

StatusSubtypeAssignedTask
ResolvedNone
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedJoe
ResolvedDzahn
Resolvedhashar
ResolvedJdforrester-WMF
ResolvedLadsgroup
ResolvedMoritzMuehlenhoff
Resolvedjijiki
ResolvedMoritzMuehlenhoff
ResolvedTrizek-WMF
ResolvedDzahn
Resolved Gilles
ResolvedDzahn
ResolvedRequestPapaul
Resolvedjijiki
DeclinedNone
ResolvedDzahn
ResolvedDzahn
ResolvedPapaul
ResolvedCmjohnson
ResolvedRequestCmjohnson
ResolvedRequestPapaul
ResolvedAndrew
ResolvedArielGlenn
ResolvedDzahn
ResolvedLegoktm
ResolvedPapaul
ResolvedDzahn
Declined Gilles
ResolvedVolans
ResolvedDzahn
ResolvedLegoktm
ResolvedPleaseStand
ResolvedJoe
Resolvedtstarling
ResolvedArielGlenn
ResolvedJoe
Resolvedtstarling
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedLegoktm
ResolvedJdforrester-WMF
ResolvedDaimona
ResolvedDaimona
ResolvedJdforrester-WMF
ResolvedJoe
ResolvedJMeybohm
ResolvedJoe
ResolvedJoe
ResolvedJoe
ResolvedJoe
ResolvedKrinkle
ResolvedJoe
ResolvedClement_Goubert
ResolvedClement_Goubert
ResolvedClement_Goubert
ResolvedMainframe98
ResolvedJoe
ResolvedZabe

Event Timeline

This is hard because the commit that added support for php 8, marked it as no longer supporting php 7.2. And we want to support both in these tests :(

Hmm, i know general practice is to require exact version in vendor.git, but I wonder if this is a case where it would be acceptable to "1.4.2|1.4.1" since both versions are essentially identical, and its just which version of php they are marked as supporting

Hmm, i know general practice is to require exact version in vendor.git, but I wonder if this is a case where it would be acceptable to "1.4.2|1.4.1" since both versions are essentially identical, and its just which version of php they are marked as supporting

The "problem" with doing that becomes if/when someone runs composer using a different version of PHP to what was used last time, the version installed may change.

1.4.1 says php: ^5.6.99|^7.0
1.4.2 says php: >=7.3

Change 836846 had a related patch set uploaded (by Jforrester; author: Jforrester):

[mediawiki/vendor@master] Raise onoi/message-reporter to 1.4.2 for PHP 8.0 compat

https://gerrit.wikimedia.org/r/836846

Change 836846 merged by jenkins-bot:

[mediawiki/vendor@master] Raise onoi/message-reporter to 1.4.2 for PHP 8.0 compat

https://gerrit.wikimedia.org/r/836846