Goal: Connect the priorities of the Community Wishlist and other tech priorities with the Wikimedia Hackathon 2016
Closed, ResolvedPublic

Description

The hackathons in 2015 had great showcases of prototypes but a low impact on actual improvements for our editors and readers. In order to improve this situation, we are betting on promoting tasks identified by our communities as possible hackathon projects.

Let's incubate the idea here. The list of proposals will move to the event's wiki page right before T120828: Open registration for Wikimedia Hackathon 2016.

Criteria for projects

  • Scope is defined enough to be possible in a couple hacking days, or there's a small-scope piece of the proposal that could be broken off from the larger idea.
  • Non-controversial, won't need further community discussion before you get started
  • Minimal design needs

Projects recommended by Community-Tech (WIP)

The priority order is based on the number of support votes the proposal got at the Technical Wishlist Survey. The full table is here, with links to the proposals:

#15: T120733: Improve date range searches on Special:Contributions Well scoped, clearly defined, minimal design.
https://meta.wikimedia.org/wiki/2015_Community_Wishlist_Survey/Moderation_and_admin_tools#Improve_date_range_searches_on_Special:Contributions

#21: T120462: Reduce edit conflicts by treating different parts of the page as separate A very open-ended, vague proposal, but there's a small chunk that would be perfect: "Treat the addition of a template at the top of an article or a category at the end as not conflicting with the alteration of the contents in between." There's also possible room for creative devs to figure other small-scale, non-controversial improvements along those lines. Improvements here likely will also benefit T121469: Improve diff compare screen.
https://meta.wikimedia.org/wiki/2015_Community_Wishlist_Survey/Editing#Halve_edit_conflicts

#25: T120788: Tool to use Google OCRs in Indic language Wikisource
https://meta.wikimedia.org/wiki/2015_Community_Wishlist_Survey/Wikisource#Tool_to_use_Google_OCRs_in_Indic_language_Wikisource

#27: T109561: Add non-exact title search to Special:Undelete and corresponding API Well-defined, would be very useful for admins. This task would provide a means of searching for deleted pages.
https://meta.wikimedia.org/wiki/2015_Community_Wishlist_Survey/Search#Provide_a_means_of_searching_for_deleted_pages

#43: T22307: Generate automatic summary /* blah */ when I manually add a section heading when editing Well-defined, not controversial, could be very helpful.
https://meta.wikimedia.org/wiki/2015_Community_Wishlist_Survey/Editing#Generate_automatic_summary_.2F.2A_blah_.2A.2F_when_I_manually_add_a_section_heading_when_editing

In addition, the organizers (Wikimedia Israel) would like to create a specific working group for developing existing/new mobile apps based on MediaWiki APIs, specifically looking at T88746: Upload photos on Wikipedia mobile app's edit screen - commons mobile app, or developing another community needed mobile app.

Additional projects recommended by TCB-Team

Additional projects recommended by Wikidata team

Background

The Community-Tech team is organizing a Community Wishlist Survey that will result in a prioritized backlog of tasks. That team will work on some of the tasks but not all. What about using the developer energy around the Wikimedia-Hackathon-2016 to get more tasks of that list resolved?

The idea can be extrapolated to other wishlists in Wikimedia, like German Wikipedia's Technische Wünsche 2015, Wikisource's technical needs, even Possible-Tech-Projects...

We could match identified tasks with Wikimedia developers willing to work on them with local developer groups willing to participate in the hackathon (T119694).


See Also:

Related Objects

StatusAssignedTask
DuplicateQgil
ResolvedQgil
ResolvedQgil
ResolvedChen_WMIL
ResolvedQgil
Resolvedkaldari
Resolvedkaldari
Resolvedkaldari
Resolvedkaldari
ResolvedDannyH
Resolvedkaldari
Resolvedkaldari
Resolvedkaldari
Resolvedkaldari
DeclinedQgil
DeclinedNone
ResolvedJohan
ResolvedJohan
ResolvedRfarrand
There are a very large number of changes, so older changes are hidden. Show Older Changes
Danny_B added a subscriber: Danny_B.Jan 9 2016, 6:25 AM
Qgil moved this task from Backlog to Doing on the DevRel-January-2016 board.Jan 12 2016, 1:50 AM
Johan added a subscriber: Johan.Jan 18 2016, 1:12 PM
Restricted Application added a subscriber: JEumerus. · View Herald TranscriptJan 20 2016, 12:14 AM
Qgil added a comment.Jan 21 2016, 10:03 AM

@Aklapper, sorry for being late with the text for the CW related tasks that we agreed on Tuesday:

IMPORTANT:

The Wikimedia Hackathon 2016 (Jerusalem March 31 - April 3) focuses on #Community-Wishlist-Survey projects and we have some budget for sponsoring volunteer developers. THE DEADLINE TO REQUEST TRAVEL SPONSORSHIP IS TODAY, JANUARY 21. We can make exceptions for developers focusing on Community Wishlist projects until the end of Sunday 24, but not beyond. If you or someone you know is interested, please REGISTER NOW.

IMPORTANT: If you are a community developer interested in working on this task: The Wikimedia Hackathon 2016 (Jerusalem, March 31 - April 3) focuses on #Community-Wishlist-Survey projects. There is some budget for sponsoring volunteer developers. THE DEADLINE TO REQUEST TRAVEL SPONSORSHIP IS TODAY, JANUARY 21. Exceptions can be made for developers focusing on Community Wishlist projects until the end of Sunday 24, but not beyond. If you or someone you know is interested, please REGISTER NOW.

(Slightly tweaked comment added to 106 tasks (excluded those with "Investigation" prefix) in the #Community-Wishlist-Survey project.)

Qgil added a comment.Jan 26 2016, 7:45 AM

@Lydia_Pintscher, the description mentions T117592: Add page view stats to page information pages but it is closed as a duplicate of T43327: Add page views graph(s) to MediaWiki's info action for Wikimedia wikis. Is that the task that should be featured instead?

Yes. Thanks for spotting. Changing it.

Qgil renamed this task from Connect the priorities of the Community Wishlist and other tech priorities with the Wikimedia Hackathon 2016 to Goal: Connect the priorities of the Community Wishlist and other tech priorities with the Wikimedia Hackathon 2016.Jan 26 2016, 1:46 PM
Qgil raised the priority of this task from Low to Normal.
Qgil added a comment.Jan 26 2016, 2:00 PM

A summary of where we are at:

It feels that we have come a long way. :)

  • We defined the idea.
  • We brought Community Tech, TCB & Wikidata teams to this game
  • We brought WMF Product and Technology teams to this idea.
  • We promoted the Hackathon among CW-related circles.

This is an established idea now. We "only" need to assure that Hackathon participants do take Community Wishlist tasks.

  • One factor that we control is who gets travel sponsorship approval. Developers with a credible plan to work on CW tasks should get preference.
  • One factor where we have some influence but no control is who gets travel approval at the WMF.

These two processes are happening as we speak, with most developers from these groups being confirmed between this and next week.

Still, I expect a significant amount of work to do during February and March, helping developers finding projects, identifying the projects that move forward, and supporting them so they start their discussions and coordination online, allowing for more effective collaboration during the days in Jerusalem.

While I have been a probably-ok assigned of this task until now, I think the new phase requires someone with more time available / allocated to follow and push the process more closely. /me is asking privately to a couple of people...

TheDJ updated the task description. (Show Details)Jan 27 2016, 10:14 AM
Qgil added a comment.Jan 27 2016, 10:37 AM

More about the work that could be done between now and the Hackathon.

This type of goal is new and brings all of us out of our comfort zone. However, maybe a couple of conversations could dissipate the fog and make us realize that the work left before the Hackathon is not that much?

I think the work basically consists about checking the current list of registered participants and

  • check for explicit matches and documented them in the related tasks (i.e. Mary says she will work on T123, then check that Mary has that task assigned (if not, ask) and move the task to a Confirmed column in the Hackathon workboard)
  • check for participants with vague or no explicit plan and help them choose a project (this might require a email / Conpherence communications, because many people might not like the fact of being proposed projects in public, with the (perceived or real) social pressure that they might feel.
  • help the projects confirmed to warm up and do preparations before the Summit

Let's say that we expect about 160 participants. Contacting all of them one by one would be a lot of work. However, we have some defined groups:

  • Volunteers with travel sponsorship. In principle volunteers are selected because they have an interesting plan, so not much work would be expected here at least covering the basics.
  • Wikimedia volunteers covering their own expenses. We can expect the majority of them knowing what to do and having some plan in mind, related with the CW or not.
  • WMF/WMDE professional developers. One-to-many communication should help here, communicating our expectations (which we are doing already) and then offering help to individuals welcoming recommendations.
  • Local newcomer developers, which we could expect divided in two subgroups:
    • Local groups with a clear field of expertise (i.e. Android developers), one-to-many communication might work here as well, discussing with the group their best fit for projects.
    • Individual local developers. From all, these are probably the ones requiring more individual attention. Local wikimedians might help here as well, since they will share language and background.

So yes, it is work, but can be reasonably organized in the remaining weeks.

Qgil added a comment.Jan 28 2016, 11:59 AM

I made a pass through all the sponsorship requests, and it is clear that our campaign is working so far. Many candidates are mentioning CW tasks. Some mention decidedly just one. Some mention two or three where they could work.

In a few days we should have a first wave of candidates accepted, and then it would be good to have some instructions for them, i.e. indicating how to update the description of the tasks they are going to work on, and also perhaps how to update https://www.mediawiki.org/wiki/Wikimedia_Hackathon_2016#Main_Development_Focus

While this is happening, WMF developers and other participants without sponsorship should be registering as well, hopefully some of them identifying other CW tasks (I haven't checked yet). Probably some tasks will get a critical mass of interests and should be highlighted (even as "Thank you, we seem to be fine"). While other good tasks might be still orphan, which we should also highlight to get developers' attention.

Qgil moved this task from Backlog to Doing on the Liaisons-February-2016 board.Feb 2 2016, 1:47 PM
DannyH updated the task description. (Show Details)Feb 5 2016, 8:51 PM
DannyH added a subscriber: Jdforrester-WMF.EditedFeb 24 2016, 8:57 PM

@Jdforrester-WMF posted on T120475: Make it easier to cite different pages from a book as one reference: "I think this would be a very very bad idea for a GSoC project." (You can see his rationale on that ticket.)

Should we take that off the list of suggested Hackathon/GSoC projects?

@Jdforrester-WMF posted on T120475: Make it easier to cite different pages from a book as one reference: "I think this would be a very very bad idea for a GSoC project." (You can see his rationale on that ticket.)

Should we take that off the list of suggested Hackathon/GSoC projects?

@Jdforrester-WMF originally removed it from the Possible-Tech-Projects too, which seems sensible. So, apparently - the task is no more a suggested GSoC project.

Qgil updated the task description. (Show Details)Feb 25 2016, 9:06 AM
Qgil updated the task description. (Show Details)Mar 23 2016, 9:53 PM

#47 T120738: List of content contributors is being pushed as a GSoC project, and there seems to be candidates interested. Therefore, I removed it from the description.

Nemo_bis removed a subscriber: Nemo_bis.Mar 25 2016, 8:28 AM
Sigma updated the task description. (Show Details)Mar 31 2016, 8:21 PM
kaldari updated the task description. (Show Details)Mar 31 2016, 9:01 PM
kaldari updated the task description. (Show Details)
kaldari updated the task description. (Show Details)Mar 31 2016, 10:34 PM
kaldari updated the task description. (Show Details)Apr 1 2016, 3:06 AM
kaldari updated the task description. (Show Details)Apr 1 2016, 4:10 AM
Qgil updated the task description. (Show Details)Apr 1 2016, 5:22 AM
Niharika updated the task description. (Show Details)Apr 1 2016, 12:45 PM
01tonythomas updated the task description. (Show Details)Apr 1 2016, 12:48 PM
Qgil closed this task as Resolved.Apr 3 2016, 9:30 PM

https://www.mediawiki.org/wiki/Wikimedia_Hackathon_2016/Showcase and this query seem to indicate that there has been progress on eight Community Wishlist tasks during the hackathon.

While the number is perhaps modest, I believe this first experience has been positive. The message that CW tasks are relevant as hackathon projects was clearly communicated during the event, we can consider it widespread among hackathon participants, and it was well received.

In future editions we should focus on promoting CW tasks sooner and organizing interest, possible contributors, and possible plans before the event.

Thank you for all the feedback and contributions! Wikimania-Hackathon-2016 is the next stop. :)

DannyH moved this task from Epic/Tracking to Archive on the Community-Tech board.Apr 16 2016, 12:23 AM
Tobi_WMDE_SW moved this task from Incoming to Done on the TCB-Team board.Apr 19 2016, 11:22 AM
Danny_B removed a subscriber: RTL.
Restricted Application added a project: I18n. · View Herald TranscriptJul 3 2016, 11:00 PM