Convert Special:Preferences to OOUI
Closed, ResolvedPublic

Tokens
"Barnstar" token, awarded by RandomDSdevel."Love" token, awarded by Niharika."Love" token, awarded by Samwilson."Love" token, awarded by Elitre."Love" token, awarded by TBolliger."Love" token, awarded by Trizek-WMF."Love" token, awarded by Liuxinyu970226."Love" token, awarded by Volker_E."Love" token, awarded by Jan_Dittrich."Love" token, awarded by Ladsgroup.
Assigned To
Authored By
Florian, Nov 4 2015

Related Objects

StatusAssignedTask
OpenNone
OpenNone
OpenNone
ResolvedVolker_E
Resolvedmatmarex
DeclinedNone
Declinedmatmarex
Resolvedmatmarex
Resolvedmatmarex
Resolvedmatmarex
Resolvedmatmarex
Resolvedmatmarex
ResolvedEsanders
ResolvedMooeypoo
ResolvedMooeypoo
ResolvedMooeypoo
ResolvedEsanders
Resolvedmatmarex
ResolvedEsanders
ResolvedEsanders
Resolvedmatmarex
Resolvedmatmarex
ResolvedVolker_E
DeclinedNone
Resolvedmatmarex
Resolvedmatmarex
ResolvedEsanders
Resolvedmatmarex
ResolvedVolker_E
Resolvedmatmarex
Resolvedmatmarex
Resolvedmatmarex
ResolvedVolker_E
ResolvedVolker_E
Resolvedmatmarex
ResolvedVolker_E
There are a very large number of changes, so older changes are hidden. Show Older Changes

Another before/after pair, of the Notifications page:

BeforeAfter

Love it. One thing - the "Restore all default..." does not seem like a link anymore. Seems more like a warning message one gets when they have left some form fields unfilled. And the bright red is not helping. It's a destructive action, yes, but there is a confirmation page for it.

Change 352071 merged by jenkins-bot:
[mediawiki/core@master] Special:Preferences: Use OOjs UI

https://gerrit.wikimedia.org/r/352071

Jdforrester-WMF closed this task as Resolved.Nov 14 2017, 11:00 PM

There'll be a bunch of follow-ups (not least, updating Minerva's hack on this to make it work there), but declaring this Done for now.

Change 394804 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/core@master] Revert "Special:Preferences: Use OOjs UI" and follow-ups

https://gerrit.wikimedia.org/r/394804

Change 394804 merged by jenkins-bot:
[mediawiki/core@master] Revert "Special:Preferences: Use OOjs UI" and follow-ups

https://gerrit.wikimedia.org/r/394804

matmarex reopened this task as Open.Dec 2 2017, 10:13 PM
matmarex removed matmarex as the assignee of this task.

Change 394874 had a related patch set uploaded (by Chad; owner: Bartosz Dziewoński):
[mediawiki/core@wmf/1.31.0-wmf.10] Revert "Special:Preferences: Use OOjs UI" and follow-ups

https://gerrit.wikimedia.org/r/394874

Change 394874 merged by Chad:
[mediawiki/core@wmf/1.31.0-wmf.10] Revert "Special:Preferences: Use OOjs UI" and follow-ups

https://gerrit.wikimedia.org/r/394874

I reverted Special:Preferences back to the old interface, and the revert was deployed to all wikis today. For anyone who doesn't want to check Gerrit, here's a copy of the explanation from the commit message:

The number of issues with the new interface is unacceptable and we
will not be able to fix them reasonably quickly. See subtasks of
T180538 for the list of issues, raised both by the Wikimedia community
and by WMF employees.

I should have pushed back harder against the merging of this half-baked
change with the promise that we'll fix it later. I convinced myself
that the regressions were not so noticeable and that the issues that
were pointed out will in fact be fixed by someone. Predictably,
however, regressions were bad and the only person fixing the issues
was me.

I am not going to work nights to make this page decent again within a
reasonable timeframe; I'm not sure if I'd even be able to since many
issues are problems with the design rather than the implementation. No
one else seems to be working on improving it, therefore I am reverting
the change.

On the bright side, this work has resulted in a number of improvements
to HTMLForm and Preferences code, which are not being reverted here:
https://gerrit.wikimedia.org/r/#/q/topic:T117781.

If anyone reattempts this, I recommend gating the new interface behind
a configuration variable and URL parameter, like we did with
$wgOOUIEditPage in the past, and testing thoroughly in production
before enabling it for everyone.

Change 398071 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/core@master] Revert "Revert "Special:Preferences: Use OOjs UI" and follow-ups"

https://gerrit.wikimedia.org/r/398071

Change 398071 merged by jenkins-bot:
[mediawiki/core@master] Special:Preferences: Create flag to enable OOjs UI

https://gerrit.wikimedia.org/r/398071

The new version of the form is now available for testing by adding the URL parameter 'ooui=1' when viewing preferences, e.g. https://en.wikipedia.beta.wmflabs.org/wiki/Special:Preferences?ooui=1 (only on Beta Cluster right now, it will go out to the production wikis next week, per the usual schedule). Please note that this work is not completed; a few issues which need to be worked on are listed on the subtask T180538, and any issues not listed there should be added :) . I imagine this will be announced in Tech News or whatever when it is closer to being done. I don't know what the timeline is.

(Adding T186842 as a subtask, since it seems like Special:GlobalPreferences will be enabled on production wikis before the Special:Preferences rework.)

If you're doing it wiki-by-wiki, I offer Persian Wikipedia. They were pretty happy about the change when it got deployed.

(Experimenting with a new tag. This is an FYI to ambassadors per what https://phabricator.wikimedia.org/T117781#4195310 states.)

Change 461182 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/core@master] Special:Preferences: Enable OOUI mode by default

https://gerrit.wikimedia.org/r/461182

Change 461182 merged by jenkins-bot:
[mediawiki/core@master] Special:Preferences: Enable OOUI mode by default

https://gerrit.wikimedia.org/r/461182

Izno added a subscriber: Izno.Sep 18 2018, 10:13 PM

I filed T204780: OOUI has a border in Timeless Special:Preferences but didn't want to make it a blocker (since a) it's Timeless and b) it's minor).

I filed T204780: OOUI has a border in Timeless Special:Preferences but didn't want to make it a blocker (since a) it's Timeless and b) it's minor).

Good call.

Jdforrester-WMF closed this task as Resolved.Sep 27 2018, 1:01 AM
Jdforrester-WMF assigned this task to Volker_E.

This has been rolled out to all wikis including enwiki today. Thanks for everyone involved in this process, especially @matmarex, @Jdforrester-WMF, @Esanders and @Ryasmeen!

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSep 27 2018, 6:03 PM
Samwilson awarded a token.
Niharika awarded a token.